[mythtv] Failed recording marked recorded anyway

Bruce Markey bjm at lvcm.com
Fri Jan 13 22:14:55 UTC 2006

Joseph A. Caputo wrote:
> DISCLAIMER:  I am running SVN from just before the LiveTV overhaul 
> (revision 7569), but I've been keeping up on the -dev and -commits list 
> and haven't seen anything addressing this.  Please beat me with a wet 
> noodle if this has actually been fixed.
> OK, so in fiddling with my system recently I apparently screwed up my 
> second tuner device, so everything that's been scheduled to record on 
> that card has silently failed.  Worse, though... even though the 
> recordings failed, they were still inserted into the 'oldrecorded' 
> table, so later showings didn't get recorded.
> Here are some relevant entries from my logfile (the stuff about not 
> finding the input are because I screwed up my second tuner):
> ****************************************************************************************
> 2006-01-12 20:57:03.554 TVRec(1): Changing from None to RecordingOnly
> 2006-01-12 20:57:03.931 ChannelBase: Could not find input: Tuner 0 on 
> card when setting channel 4
> 2006-01-12 20:57:03.934 TVRec(1) Error: Failed to set channel to 4. 
> Reverting to kState_None
> 2006-01-12 20:57:03.936 TVRec(1): Changing from RecordingOnly to None
> 2006-01-12 20:57:03.967 scheduler: Finished recording
> 2006-01-12 20:57:03.991 scheduler: Started recording
> 2006-01-12 20:57:10.828 scheduler: Scheduled items
> 2006-01-12 20:57:10.863 TVRec(1): Changing from None to RecordingOnly
> 2006-01-12 20:57:11.228 ChannelBase: Could not find input: Tuner 0 on 
> card when setting channel 68
> 2006-01-12 20:57:11.231 TVRec(1) Error: Failed to set channel to 68. 
> Reverting to kState_None
> 2006-01-12 20:57:11.233 TVRec(1): Changing from RecordingOnly to None
> 2006-01-12 20:57:11.262 scheduler: Finished recording
> 2006-01-12 20:57:11.283 scheduler: Started recording
> 2006-01-12 20:57:16.043 scheduler: Scheduled items
> ****************************************************************************************
> You can see that it tried to start a recording on Channel 4, failed, 
> then (since it thought a tuner had freed up), it tried to record a 
> program that had previously been conflicted on Channel 68, and failed 
> that one as well.  Yet, both programs now have entries in the 
> 'oldrecorded' table, so later showings of either program get skipped as 
> duplicates.  Bad!

I was all psyched up to answer your question but you didn't ask one.
So is this just a complaint that you're not going to lift a finger
to do anything about and just brow beat the people who spent hundreds
of man hours creating what you have so far that you downloaded for free?
Joseph, you should know better. I'll try to answer the questions you
should have asked.

Is anything being done to track failed recordings on oldrecorded?
Yes. One of the biggest invisible changes between 18 and 19 is that
there were a lot of changes related to how we keep track of shows
during their airtime, what is stored in oldrecorded and how that
can be reused, what happens when master and slave backends restart
and it all leads to the ability to change the end time of recordings
in progress. Part of this is a new state rsAborted to mark a failed
recordings to make you aware of the problem, allow reactivate, allow
re-record and display this info after the fact on the Previously
Recorded page. This state is set certainly for a backend crash and
should be incorporated for other recording failures that can be detected.

Do I have to cower like a little girl and use SVN from before the live
TV changes? [You would have been better off phrasing this for yourself.]
No. It's been working just fine for quite a while. There are rough
spots to smooth out like anything else but the last major piece, the
transition from live to scheduled recording, went in this week. A lot
of other fixes have gone in in the meantime possibly related to the
issues you had above. Current SVN is in much better shape than 7569.

How can I fix the oldrecorded entries for these shows that didn't
record? If you'd found the problem from trying to play the recordings
from the Watch Recordings page, I would hope that you chose the
allow re-record option (duh =). Generic showings aren't supposed to
have this button but this doesn't always work out right. You can
always go to the Previously Recorded page. Sort by time may help
cluster the shows in question. The 'Enter' key shows buttons to
delete the one entry or all entries for that title. Also, on the list,
"D" is a shortcut to delete the one highlighted item. If you're not
sure of which shows were affected, go through your backend to find
the times and channels when you had this problem. If you use "-v record"
you would see the titles also.

--  bjm

More information about the mythtv-dev mailing list