[mythtv] Problems compileing latest svn

Jai jai at linknet.com.au
Thu Apr 6 06:00:17 UTC 2006


"I previously posted this in the mythtv-users list but I thought it should
have probably gone to mythtv-dev."

I seem to be having some trouble compiling mythtv from the latest SVN
source. I have tried a few different releases of the code (9611,9619 & 9620)
and I’m get the same error, although I don't get it with 0.19 stable

I'm no programmer, though the only thing I can think of is I have the wrong
version of QT (which BTW is 3.3.5) and hence qmap.h, which doesn't have the
function or something to go on.

Anyone know what is wrong here? Is this the right place to ask? Sorry if it
is not.
Compile output:
cd mythtv && qmake mythtv.pro -o Makefile
cd mythtv && make -f Makefile
make[2]: Entering directory `/home/mythtv/packages/BUILD/mythtv-0.20/ 
g++ -c -pipe -O2 -march=i586 -mcpu=i686 -fmessage-length=0 -Wall -g -
fno-strict-aliasing -march=athlon -Wall -W -O3 -Wall -Wno-switch - 
fomit-frame-pointer -D_REENTRANT  -DMMX -Di386 -DUSING_DBOX2 - 
DQT_TABLET_SUPPORT -I/usr/lib/qt3/mkspecs/default -I. -I/usr/local/ 
include -I/usr/include -I/usr/X11R6/include -I../../libs -I../../libs/ 
libmyth -I../../libs/libmythtv -I../.. -I../../libs/libavutil -I../../ 
libs/libavformat -I../../libs/libavcodec -I/usr/include -I/usr/lib/ 
qt3/include -I/usr/include -I/usr/X11R6/include -o main.o main.cpp
g++  -o mythtv main.o    -L/usr/lib/ -L/usr/lib/qt3/lib/ -L../../libs/ 
libmyth -L../../libs/libmythtv -L../../libs/libavutil -L../../libs/ 
libavcodec -L../../libs/libavformat -L../../libs/libfreemheg -L../../ 
libs/libmythui -lmythtv-0.19 -lmythavformat-0.19 -lmythavutil-0.19 - 
lmythavcodec-0.19 -lfreemheg-0.19 -lmyth-0.19 -lmythui-0.19 - 
lfreetype -lmp3lame -lasound -ljack -lraw1394 -liec61883 -lavc1394 -L/ 
usr/lib/ -L/usr/X11R6/lib/ -lXinerama -lXv -lXxf86vm -lXrandr -lqt-mt  
-lGLU -lGL -lXmu -lXext -lX11 -lm -lpthread
main.o(.text+0xff2): In function `main':
/usr/lib/qt3/include/qmap.h:133: undefined reference to  
`MythContext::OverrideSettingForSession(QString const&, QString const&)'
collect2: ld returned 1 exit status
make[2]: *** [mythtv] Error 1
make[2]: Leaving directory `/home/mythtv/packages/BUILD/mythtv-0.20/ 
make[1]: *** [sub-mythtv] Error 2
make[1]: Leaving directory `/home/mythtv/packages/BUILD/mythtv-0.20/ 

More information about the mythtv-dev mailing list