[mythtv] Current DVB problems rundown

Daniel Kristjansson danielk at cuymedia.net
Sat Sep 10 17:32:51 UTC 2005


On Sat, 2005-09-10 at 16:22 +0200, Adam Egger wrote:
> > >   Mysterious rec vs livetv problem (Adam Egger)
> > >     Need "mythbackend -v record,channel,siparser" output from
> > >     both on same channel with latest SVN.
> > 
> > Sorry, still no livetv for me with 7221 so here are my logs (full logs
> > attached).
> > It starts to get different at:
> 
> Wow! Everything works now! I just had to change the starting channel
> to something else. Then LiveTV was working again.
That is weird, what do you know about this channel?

Perhaps you can dvbsnoop it or something?

Or assuming you can change to that channel within MythTV,
try "-v channel,siparser,record" for the backend options
and capture those logs.

My guess is that the DVB driver is giving up on tuning before
we enter the signal monitor loop or something like that. On
faster and less burdened machines we never seem to get this
problem... Which would indicate they outrace the DVB timeout.

> EIT and the full scan work too for my DVB-t card (it even doesn't 
> create new channels if the channel number was changed for the 
> existing channels).
It updates any existing channels, but it should insert channels if
it doesn't find one with the similar tuning params in the DB.

> So everything's fine for me, you can remove all the Mysterious Adam
> Egger problems ;)
> A few questions: Why do you display the Signal Power on the OSD? It's
> always at 100% for me even if my antenna is turned off, wouldn't it be
> better to display the Signal/Noise? This value varies for me from 50
> to 80%.
The S/N isn't always available. The signal power is always
available even if sometimes useless. Can you create a patch for
TV::UpdateOSDSignal() that falls back to the using the S/N if
it is available and the signal value is useless? I'll review
and apply it quickly. The short name of the S/N SignalMonitorValue
is "snr"...

> And is it possible to display the Signal OSD after it disappeared?
There used to be... It causes problems for some drivers to monitor
the signal once the video is playing.

> Thank you Daniel for all the work on mythtv,
:)

-- Daniel



More information about the mythtv-dev mailing list