[mythtv] Odd performance problems with latest CVS

Todd Tidwell artist at wildstar.net
Wed Mar 23 03:59:21 UTC 2005

I just tried this using CVS from about 6:00 PM PST.  While the new configure
is awesome, I still am having the same problem with play of HDTV content
without libmpeg or xvmc.  This wasn't a problem with .17 release and I'm
wondering what could have gone wrong.

It detects my CPU as x86 (athlon) which is true and it turns on MMX.
Anything else I should maybe try?


-----Original Message-----
From: mythtv-dev-bounces at mythtv.org [mailto:mythtv-dev-bounces at mythtv.org]
On Behalf Of Daniel Thor Kristjansson
Sent: Monday, March 21, 2005 6:33 PM
To: Development of mythtv
Subject: Re: [mythtv] Odd performance problems with latest CVS

On Mon, 21 Mar 2005, Todd Tidwell wrote:
]So I upgraded last night to the latest CVS.  Happily, everything compiled
]I ran into a few problems, and I'd like some input:
]1) Previous to moving to this version, my HDTV recordings played smoothly
]without XvMC or libmpeg support turned on.  Now I have to used XVMC to even
]play them back smoothly

Try today's cvs, and rerun ./configure, it should automagically compile 
for your CPU in most cases. There was a small compile flag change to 
make gcc 3.4+ happy that is probably giving you grief. If today's patch 
doesn't help, you may want to use custom compile flags for libavcodec.

]2) Sadly, XVMC has some issues:  IT plays smoothly and does not cause any
]crashing of the frontend as it did on the .17 release (for me) but anytime
]*any* text or OSD stuff is on the screen it jumps like *crazy* until the
]OSD/text goes away.

Ok, I may have a fix for this locally, but I still have some new bugs 
in that patch that I need to fix. Try using "W" to switch to a different 
zoom, this may work around the problem.

[[I can't help you with #3]]

-- Daniel

More information about the mythtv-dev mailing list