[mythtv] MythWeb problem?

Piers Kittel mythtv at biased.org
Thu Dec 22 21:32:52 EST 2005

Hello all,

Have decided to upgrade MythTV via SVN to incorporate all the DVB 
subtitle bugfixes, works fine on my main playback machine (but not my 
secondary machine but that's for another time) but I do most of my 
management via the web interface, and I haven't updated mythtv for 3 1/2 
months, so I decided to upgrade mythweb as obviously the old version 
won't work with the new version of the backend.  Downloaded it via SVN, 
backed up the old copy and copied the new version over and followed the 
README file but I kept getting something like an "program_listing.php 
file not found" errors.  After hitting it with a stick, gave up and 
redownloaded the plugin via SVN, did the above again and now I get:

Internal Server Error

The server encountered an internal error or misconfiguration and was 
unable to complete your request.

Please contact the server administrator, webmaster at biased.org and inform 
them of the time the error occurred, and anything you might have done 
that may have caused the error.

More information about this error may be available in the server error log.

Looked in the logs, and found:

[Fri Dec 23 02:07:17 2005] [alert] [client] 
/var/www/mythweb/.htaccess: Invalid command 'RewriteEngine', perhaps 
mis-spelled or defined by a module not included in the server configuration

So looked up on Google, and added in:

LoadModule rewrite_module /usr/lib/apache2/modules/mod_rewrite.so

and restarted apache and tried again.  Same error.  Back to the logs, 
and I found:

[Fri Dec 23 02:22:17 2005] [alert] [client] 
/var/www/mythweb/.htaccess: Invalid command 'AuthDigestFile', perhaps 
mis-spelled or defined by a module not included in the server 
configuration, referer: https://mythtv:80/mythweb/

Again, looked it up and tried:

LoadModule digest_auth_module /usr/lib/apache2/modules/mod_auth_digest.so

but this time on restarting Apache:

Can't locate API module structure `digest_auth_module' in file 
/usr/lib/apache2/modules/mod_auth_digest.so: /usr/lib/libapr-0.so.0: 
undefined symbol: digest_auth_module

Googling for "Can't locate API module structure `digest_auth_module'" 
gets zero results.

Any ideas what I'm doing wrong?

The server is Apache v2.0.54 with PHP v4.3.10-15 on Debian Sarge.

Thanks very much for your help in advance.

Regards - Piers

More information about the mythtv-dev mailing list