[mythtv] [exp. patch] xv xvmc merge (v4)

Will Dormann wd at pobox.com
Fri Apr 8 13:31:49 UTC 2005

Daniel Kristjansson wrote:
>>Looks pretty good.   The OSD looks as it should, as does the video while 
>>> the OSD is present.  I can't say the same for any of the 0.17 builds 
>>> without the patch.
> Good.
>>> Unfortunately, with XvMC enabled the system is still not stable.  If I 
>>> skip forward several times in a row while playing a recording, the 
>>> entire system hangs. 

> I'm running the 6629 drivers, but I doubt the drivers have destabilized
> since then in this area. It's probably a hardware compatibility issue.
> try changing the NVreg_EnableAGPSBA=1 NVreg_EnableAGPFW=1 kernel module
> options to 0. If that doesn't solve your stability problem, then see
> if turning off AGP does. If so there is a guide in the nvidia driver
> readme on getting AGP working properly.

I've been running the 6629 drivers with 0.16 without any stability 
problems.   When I first tried 0.17 (still with 6629), I experienced 
system hangs with XvMC enabled.   This time around I tried the 7174 
drivers along with the CVS version and your patch.   Same hangs.

The thing is, I'm not even using AGP.   My MX4000 card is PCI.  The 
system (Pundit) does have AGP functionality for the onboard graphics, 
but I'm not using it.  I have disabled the onboard SIS graphics in the 
BIOS, but it still seems to be detected by linux.  But would that even 
have an effect on the stability of the nvidia card/driver ?


More information about the mythtv-dev mailing list