[mythtv] Frontend Segfault switching states. (need help with backtrace)

Marc Tousignant drayson at net1plus.com
Wed Nov 24 13:05:34 UTC 2004

Hi all, new user here.
System setup
Gentoo Linux
Kernel 2.6.9-rc2-love4 patched for tuner 47. I'm one of the lucky ones
with the new tuner in my 350..
Currently running ivtv-0.2.0-rc2w but have tried with multiple versions
including several 0.3.0. all having same problem. If there is a
recommended version please tell me.
Using the alsa sound driver for my audigy card built into the kernel.
Nvidia Kernel and GLX 1.0.6629 However I'm not using XvMC. Attempting to
compile mythtv with nvidia flag fails.

I built 0.16 and had several problems so I tried CVS, both built from
ebuilds, and am still experiencing them. If it is required that I build
by hand I will.

Unfortunately I don't have backtraces cause of some problem with GDB.

(gdb) run -v all
Starting program: /usr/bin/mythfrontend -v all
[Thread debugging using libthread_db enabled]
[New Thread -1510676768 (LWP 14324)]
[New Thread -1514423376 (LWP 14327)]

and it just sits there forever. If anyone can help me solve the GDB
problem I can get backtraces.

Problem, Frontend segfault.
How to duplicate.
Chose WatchTV watch your tv show. Escape back to menu.
When chose to watchtv again I see Changing from None to None and a
segfault immediately following.
Can be cause by all the following:
watch tv to menu to watch tv - result crash
watch tv to menu to watch recording - result crash
watch recording to menu to watch tv - result crash
watch recorcing to watch recording - result crash

I have not tried watching dvd so that might cause it too.

More information about the mythtv-dev mailing list