[mythtv] mythfilldatabase problem or my stupidity?

Craig Tinson craig at 8010.co.uk
Tue Aug 31 07:16:38 EDT 2004

hey guys.. first post to the -dev mailing list.. so hope it's the right place..

have compiled and got cvs working as of yesterday.. but am having a problem with mythfilldatabase..

if I run it by itself .. or pass it a file ie: 
mythfilldatabase --file 1 -1 /tmp/bleb-org

I get:
Query was:
SELECT channum FROM channel WHERE chanid = 1000;
No error type from QSqlError?  Strange...

for each attempted insert..

to try to diagnose this is I set mysql.txt to point to another MySQL server (also running myth-cvs) and got the same response..

then on a hunch I copied the xml file to another machine with an rpm based install.. pointed the mysql.txt at the first machine (with the cvs install) and ran mythfilldb on that.. and it worked..

if I then go back to the first machine and try it again.. I just get a load of "duplicate entries" there.. so am *pretty* sure it isn't a qt_MySQL issue and that mythfilldb is actually talking to the mysql server correctly..

is mythfilldb broken at the moment in cvs?

sorry for the extended email.. just wanted to get in all the stuff I've tried as this is the first post to -dev..



More information about the mythtv-dev mailing list