[mythtv] BUG? Can't skip when in-progress recording finishes

Joseph A. Caputo jcaputo1 at comcast.net
Fri Apr 30 14:04:41 EDT 2004

On Friday 30 April 2004 13:28, Bruce Markey wrote:
> Joseph A. Caputo wrote:
> > I was watching 'Survivor' as it was being recorded last night, and
> > since I have an M-179 I was forced to use the Jump keys to skip the
> > commercials.  I noticed that when the in-progress recording
> > finished, I lost the ability to jump.  The OSD would come up but it
> > jumped zero seconds.  FF/REW still worked.  I exited the recording
> > (saving position) and then started watching again and was able to
> > jump around again with no problems.
> This is a known problem and the workaround is exactly what you
> did, save and exit then start playback again.

Yeah, I vaguely recall seeing something about this on the list a while 
ago... IIRC, the problem was actually worse, and this is the 'fixed' 
behavior (a workaround is better than nothing, neh?)

> When playback starts during a record in progress, the player
> has to ask the encoder for keyframe information so that it can
> use new position map info as it is added. This isn't necessary
> for a completed recording where there is a complete seektable.
> When the recording ends, the encoder goes away so the player
> can no longer ask it for info. The problem that you are seeing
> is that there is no provision to notice that the encoder is
> gone and switch to finding the info as it would with a
> pre-recorded show.
> If you rewind and move around it works fine and if you had
> skipped to the end before the recording ended it would also
> be happy. Also playing without seeking works normally. It's only
> when you seek forward into new territory after the recording
> ends that the problem shows up.

Thanks for the explanation!


More information about the mythtv-dev mailing list