[mythtv] large file when recording and watching

Joseph A. Caputo jcaputo1 at comcast.net
Thu Apr 22 09:34:58 EDT 2004

On Wednesday 21 April 2004 19:42, Mark Covington wrote:
> > Yes... your system specs & Myth version, at minimum, might help.
> > Otherwise how are we supposed to judge whether your system may or
> > may not be underpowered for simultaneous recording & playback?
> >
> > -JAC
> Sorry, i assumed people had read my previous email, I realized that
> after I sent it, and should have sent a followup with more info.
> The machine is a Athlon 1.0GHz in a Shuttle SS40G w/ 192MB Ram on
> RedHat9.  The machine was running fine for the past year running
> various versions of Myth CVS.  I'm currently running the most recent
> CVS and still see the problem and have for the past month.  I've
> distcleaned/recompiled multiple times, and even tried downgrading to
> 0.14, but none of that worked.
> Since the machine was fine before and started having this problem
> recently I strongly suspected a software issue instead of hardware.
>  From what I remember on myth-commits there hasn't been any
> significant changes in the player that would dramatically increase
> the CPU usage.  I also fell prey to the recent scheduling delay due
> to not checking for duplicates.  The recent patch solved that
> problem.  It was sometime during that period (the past month) that I
> also noticed the large file problem.  I haven't made any changes to
> other software (OS updates, new kernel, etc).
> What do you suspect is happening?  That CPU usage is spiking during
> record/watch so compression cannot occur and instead of dropping
> frames the recorder switches to some uncompressed mode?  I guess the
> nuvinfo wouldn't be updated then?

I don't think Myth ever 'drops into' an uncompressed mode.  Raw video 
would be *really* huge (I think even bigger than what you're seeing).  
How's your signal quality?  Has it changed (for the worse) recently, or 
have you 'jiggled' your cable maybe?  Large(r) file sizes than 'normal' 
usually indicate a source with lots of noise that can't be compressed 
as efficiently.

1.0 GHz/192 MB RAM is a bit on the skimpy side for recording 1 stream + 
watching another, however, AFAIK you'd be more likely to see dropped 
frames and/or choppy playback in that case rather than increased file 
sizes.  Given that downgrading didn't solve your problem, I'd suspect 
some other change in your system (signal quality, new kernel, hardware 
changes?), but I'm afraid you've exhausted my expertise in this area.

Anyone else care to chime in?


More information about the mythtv-dev mailing list