[mythtv] Audio problem with line-in

Antonio Larrosa Jiménez mythtv-dev@snowman.net
Tue, 19 Nov 2002 01:33:44 +0100


I have a problem with MythTV 0.7 which keeps me from using it.
I'm using an Avermedia AverTV card (bt878 based, mono, no radio tuner) and 
an SB PCI 128 (ens1370). The TV card has an external cable that connects 
to the sound card's line-in to get the audio.

The problem is that if I set the line-in as recording source and then start 
MythTV, then when I pause the TV, the sound continues playing (through the 
line-in) and when I make it continue playing, then I can hear both the 
"old" audio (from the paused tv, played by MythTV) and the current TV 
audio (which is directly played from the line-in).

I've read that I should mute the line-in channel, but then, there's no 
audio at all (using both alsa 0.9.0_cvs20020320 and oss 3.9.7f). Yes, I've 
tried to change the input gain, but it seems I cannot set it for my sound 
card (?).

I've also tried to use the btaudio module to get the audio without having 
to use the sound card's line-in, but it seems it doesn't work with my tv 
card (bt878 rev17). All I get when loading that kernel module is a new 
mixer with 3 channels which seem to do exactly the same, no matter from 
which one I record (they're exclusive, I can only set the record source 
from one of them each time). So, when I use
sox -c 1 -w -r 32000 -t ossdsp /dev/dsp2 -t ossdsp /dev/dsp
all I get is "clicks" and "pops" static noise (from every of the three 
channels without any difference).

Can someone tell me if this can be solved somehow? or is my soundcard 

Thanks, and congratulations for the great app.

Antonio Larrosa Jimenez
KDE core developer - larrosa@kde.org
Furious activity is no substitute for understanding.