[mythtv] Segfault... still

Tony Pace mythtv-dev@snowman.net
09 Dec 2002 17:55:31 -0800

Sorry to be a pain.  I completely removed MythTV, database and all. Then
downloaded todays CVS, everything compiled and installed fine but I
still get a segfault running mythtv.

When I try to create a recording profile, I go through all the settings,
when I click finish it just goes back to (create new profile).  The
output in the terminal is "setValue(" thats it.  Is this the problem? 

Here's bt output of mythtv when I run it alone;

(gdb) run
Starting program: /usr/local/bin/mythtv 

(no debugging symbols found)...[New Thread 8192 (LWP 8799)]
[New Thread 16385 (LWP 8833)]
[New Thread 8194 (LWP 8834)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 8192 (LWP 8799)]
0x4008a4c6 in WriteStringList(QSocket*, QStringList&) ()
   from /usr/local/lib/libmyth-0.8.so.0
(gdb) bt
#0  0x4008a4c6 in WriteStringList(QSocket*, QStringList&) ()
   from /usr/local/lib/libmyth-0.8.so.0
#1  0x081ba810 in ?? ()
#2  0x400ac158 in vtable for ThemedMenu () from
#3  0x081ba7b0 in ?? ()
Cannot access memory at address 0x1



Tony Pace <tony@pcom.dhs.org>