[mythtv] My RedHat 8 Setup VS. Docs

Andrew De Ponte mythtv-dev@snowman.net
Sun, 8 Dec 2002 02:17:07 -0800

K, I forked out the bucks and got a machine for MythTV. It an Athlon 2100
with a 160 GB harddrive and 512 meg of ram DDR 2100. I installed red hat 8.0
off the bat because someone had just posted a success and a howto on it.
I got all the pre reqs installed I think because I followed the howto. The
problem is this when I do the configure first thing off the bat for
libavcodec everything looks fine, but when i run make after that I get:

[adeponte@myth mythtv-0.7]$ make
make: *** No rule to make target `/mkspecs/linux-g++/qmake.conf', needed by `Makefile'.  Stop.

Please help me. Where do I get qmake. What package do I have to get and
install on redhat 8.0 to get qmake installed? Please help!!

On (12/03/02 16:58), Nathan Langley wrote:
> Delivered-To: adeponte@localhost.cyph.org
> From: Nathan Langley <nathan@viptx.net>
> To: rkulagow@rocketmail.com
> Cc: mythtv-dev@snowman.net
> User-Agent: Internet Messaging Program (IMP) 3.2-cvs
> X-Originating-IP: 
> Subject: [mythtv] My RedHat 8 Setup VS. Docs
> Errors-To: mythtv-dev-admin@snowman.net
> X-BeenThere: mythtv-dev@snowman.net
> X-Mailman-Version: 2.0.12
> Precedence: bulk
> Reply-To: mythtv-dev@snowman.net
> X-Reply-To: nathan@higheriq.com
> List-Help: <mailto:mythtv-dev-request@snowman.net?subject=help>
> List-Post: <mailto:mythtv-dev@snowman.net>
> List-Subscribe: <http://www.snowman.net/mailman/listinfo/mythtv-dev>,
> 	<mailto:mythtv-dev-request@snowman.net?subject=subscribe>
> List-Id: Development of mythtv <mythtv-dev.snowman.net>
> List-Unsubscribe: <http://www.snowman.net/mailman/listinfo/mythtv-dev>,
> 	<mailto:mythtv-dev-request@snowman.net?subject=unsubscribe>
> List-Archive: <http://www.snowman.net/pipermail/mythtv-dev/>
> Date: Tue,  3 Dec 2002 16:58:25 -0600
> Here are the instructions as promised.  I went a diff way for the setup
> (probably because I did not read the docs)
> Section 2.1.2
>   I did not use the RedHat package manager to do this.  I did not install KDE or
> KDE software Develop.  This is what I did.
> MYSQL:  # must be root -- use su - to get a root shell
>    up2date --solvedeps mysql
>    up2date --solvedeps mysql-server
> QT: 
>    up2date --solvedeps qt
>    up2date --solvedeps qt-MySQL  # Case Sensitive
> This will download and install all the necessary packages for QT and MYSQL
> If you dont have internet access I cant help you and you are probably not
> reading this anyway.
> Section 4.1.2  
>   RedHat sets up all the QT Env. Variables correctly when you run up2date.  All
> you should have to do now is run /sbin/ldconfig as root (su -)
> Section 5.3
>   I had one bitch of a time setting this up.  All I had to do was run export
> LANG=C before I ran perl Makefile.PL.  That cleared it up.  I did use CPAN to
> install all the modules.  The XML::Twig that comes from RedHat seemed to be
> broken so I reinstalled it with the Perl CPAN Module too.
> Section 7.1.2
>   Ok I had some serious problems with the sound at first.  RedHat seems to set
> up the SBLive line in incorrectly and makes it a gain channel.  Dont know why
> this is and got tired of fucking with it so I just put in my Ensoniq Audio Pci
> and it worked great.  Good luck if you have a Sound Blaster Live.  I did not us
> Alaa for either I was using the default OSS stuff RedHat provides.
> If you want to include any of this in the DOCS feel free too.  You can put my
> email address in there and I will answer peoples questions.  I have also got
> MythTv working on Slackware 8.0 if you want a write up for the DOCS I can give
> you one but I will need some time.  It was a BITCH to get working in Slack.
> -- 
> Nathan Langley
> Linux > BSD > MacOS > DOS > Windows
> _______________________________________________
> mythtv-dev mailing list
> mythtv-dev@snowman.net
> http://www.snowman.net/mailman/listinfo/mythtv-dev