[mythtv] Possible bug or maybe I'm too much of a newbie

Chris Pinkham mythtv-dev@snowman.net
Sat, 7 Dec 2002 01:55:47 -0500 (EST)

First of all, great software.  I setup my first full MythTV box tonight
at home and have it recording something right now.

I had a problem (my fault) with something and was looking in the source
code to try to track it down and came across something in
libs/libmythtv/tv.cpp that I think is a bug.

In TV::GetNextChannel, around line 1812, there is the following code:

    QString thequery = QString("SELECT %1 FROM "
                               "channel,capturecard,cardinput "
                               "WHERE channel.channum = \"%1\" AND "
                               "channel.sourceid = cardinput.sourceid AND "
                               "cardinput.inputname = \"%2\" AND "
                               "cardinput.cardid = capturecard.cardid AND "
                               "capturecard.videodevice = \"%3\";")

It looks like it supplies 4 args but only uses 3 since %1 is in there
twice.  Is this supposed to be this way, I'm new to QT programming, but
looking at other code sections like this makes it look like this is a bug.
I'm assuming it should be %1, %2, %3, %4 and not %1, %1, %2, %3.

I've also been having a problem trying to checkout MythTV via cvs.  I
have used the instructions on the website but it always hangs right at the
end.  I've tried on 3 different machines and have tried checking out
MC, mythmusic, mythgallery, mythgame, and mythweb and all do the same thing.
When I trace the cvs process it appears to be hanging waiting to read
data from the cvs server.  I've tried using cvs v1.10.7 and v1.11.1p1.


** Chris Pinkham                  Linux v2.2.18, Sane v1.0.4, Cajun v3.0-8 **
** cpinkham@bc2va.org                          http://www.bc2va.org/chris/ **