[mythtv-users] seeking/editing in mythfrontend

Leo Butler leo.butler81 at googlemail.com
Sat Mar 27 17:17:04 UTC 2021

John Pilkington <johnpilk222 at gmail.com> writes:

> On 27/03/2021 08:26, Stephen Worthington wrote:
>> On Fri, 26 Mar 2021 20:50:26 -0500, you wrote:
>>> I transcode my recordings to an x264-encoded video stream in a matroska
>>> container. I use ffprobe to update the recordedseek table after
>>> transcoding. I have been doing this for a couple years.
>>> In both v0.28 and v0.29 (from the mythbuntu ppa), I was able to seek and
>>> edit these mkv files without difficulty. In v0.31/fixes from the same
>>> ppa, seeking and editing is broken for these transcoded files--it
>>> appears that any movement in the video is only by a keyframe. Playback
>>> is fine.
>>> Seeking and playback in fine in vlc and ffplay, fwiw.
>>> This seems like a regression to pre v0.28 behaviour.
>>> Has anyone seen similar behaviour? Suggestions on how to workaround the
>>> problems? Ideas about what caused the regression?
>>> TIA,
>>> Leo
>> Have you tried using the mythcommflag --rebuild option to rebuild
>> the
>> seek table using the official method?
> TTBOMK the MythTV seektable isn't used for playback of files in
> matroska format.  If you somehow create one it may upset things.  ISTR
> that 'recordings' and 'videos' get different treatment.
> I 'transcode' to mythffmpeg  -f mpegts format, which is myth-native
> and plays well for me in the frontend or via UPnP or Firestick 4k.
> But all my video cutting, mostly from mpeg2 recordings, is
> keyframe-based;  I find that acceptable.  I still get the best results
> by using ProjectX to demux and sync-adjust before remuxing, but can't
> do that for h264.

Re: -f mpegts.

I tried the following experiment. I cut a matroska container and remuxed
it to mpegts and matroska separately. I rebuilt the seektable for the
mpegts container. Seeking (in the editor or playback) works fine with
that video.

But...the file size of the mpegts is 9.5% larger than the mkv. That
9-10% overhead seems consistent across a few other recordings that I
have remuxed, too.


More information about the mythtv-users mailing list