[mythtv-users] mythfilldatabase failing

Gary Buhrmaster gary.buhrmaster at gmail.com
Sat Jan 30 18:17:39 UTC 2021

On Sat, Jan 30, 2021 at 5:22 PM Mary Strimel <mary.strimel at gmail.com> wrote:
> hello,
> Mythfilldatabase for one of my two channel lineups has stopped working. If I run "su mythtv -c tv_grab_zz_sdjson_sqlite" by itself, it downloads all the data (still not visible in mythtv). If, however, I run mythfilldatabase (again as user mythtv), I get
> 2021-01-30 12:13:50.160208 I  XMLTV config file is: /home/mythtv/.mythtv/FIOS.xmltv
> 2021-01-30 12:13:51.614035 E  XMLTV grabber returned error code 1
> 2021-01-30 12:13:52.213011 E  Malformed XML file, missing </tv> element, at line 1, Premature end of document.
> I'm pretty sure it's not a permissions issue, because FIOS.xmltv is owned by mythtv:mythtv, and it has identical permissions to my Antenna.xmltv which works fine on mythfilldatabase. I also looked inside the two files and they are pretty much identical except the lineup ID, which (I assume) is correct since, as noted, the grabber works fine when run on its own.
> Where should I look next?

Run mythfilledatabase manually adding to the command
line the "--verbose general,xmltv" option to get some
additional information that might help.

My WAG would be that you are filling up /tmp (where
the output is (temporarily) placed).

More information about the mythtv-users mailing list