[mythtv-users] mythfilldatabase failing

Mary Strimel mary.strimel at gmail.com
Sat Jan 30 17:21:59 UTC 2021

Mythfilldatabase for one of my two channel lineups has stopped working. If
I run "su mythtv -c tv_grab_zz_sdjson_sqlite" by itself, it downloads all
the data (still not visible in mythtv). If, however, I run mythfilldatabase
(again as user mythtv), I get

2021-01-30 12:13:50.160208 I  XMLTV config file is:
2021-01-30 12:13:51.614035 E  XMLTV grabber returned error code 1
2021-01-30 12:13:52.213011 E  Malformed XML file, missing </tv> element, at
line 1, Premature end of document.

I'm pretty sure it's not a permissions issue, because FIOS.xmltv is owned
by mythtv:mythtv, and it has identical permissions to my Antenna.xmltv
which works fine on mythfilldatabase. I also looked inside the two files
and they are pretty much identical except the lineup ID, which (I assume)
is correct since, as noted, the grabber works fine when run on its own.
Where should I look next?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mythtv.org/pipermail/mythtv-users/attachments/20210130/4e2e02f7/attachment.htm>

More information about the mythtv-users mailing list