[mythtv-users] mac build

John Pilkington johnpilk222 at gmail.com
Thu Jan 28 10:51:21 UTC 2021

On 28/01/2021 00:09, James Linder wrote:
>> On 28 Jan 2021, at 7:47 am, John Hoyt <john.hoyt at gmail.com> wrote:
>> On Wed, Jan 27, 2021 at 5:00 PM John Pilkington <johnpilk222 at gmail.com> wrote:
>> On 27/01/2021 20:57, John Hoyt wrote:
>>> Well, I tried edit mode from mythvideo and recordings (I hacked the bad
>>> recording into my mythbackend replacing an old recording with the bad
>>> video).  Unfortunately, I was unable to reproduce the segfault with
>>> either cutlist editor mechanism.  Basically everything just worked for me...
>>> I'm curious if there's some other underlying issue that's creating the
>>> segfault.
>>> James, have you tried telling mythbackend to rebuild the seektable? I
>>> think the command is:
>>>      mythtranscode --buildindex --allkeys --showprogress
>>>      --infile /path/to/file (for a recording)
>>>      mythtranscode --video --buildindex --allkeys --showprogress
>>>      --infile /path/to/file (for mythvideo)
>> I have had tickets about seektable regeneration in the past, and suspect
>> that the most recent work on it has used the form
>> mythcommflag --rebuild --file ccccc_yyyymmhhmmssxx.xxx     for
>> recordings, or
>> mythcommflag --rebuild --video  /may/need/full/path/to/file  for videos
>> Those commands also reset the file size.  I've used them in scripts for
>> years.  HTH...
>> Thanks John - I'm going to have to borrow that trick on some of my transcode scripts.
>> James, another thought in helping isolate the issue is trying to edit the file from mythvideo.  I.e. copy it to wherever you store you movies files, tell myth to repair its seek table with John P's commands (or the ones I suggested earlier) then try to edit the file.
> I think the solution is good but so far mo cigar: (full output in case of ..)
> [sandypit] /home/jam [1003]% mythcommflag --rebuild --file /store/10070_20210123131900.ts
> 2021-01-28 07:57:26.865199 C  mythcommflag version: fixes/31 [v31.0-85-gd3088629de] www.mythtv.org
> 2021-01-28 07:57:26.865218 C  Qt version: compile: 5.12.7, runtime: 5.12.7
> MythTV Commercial Flagger, building seek table for:
>      Speed
> Rebuild started at Thu Jan 28 07:57:27 2021
> 2021-01-28 07:57:27.885319 E  No locale defaults file for en_AU, skipping
> Rebuild completed at Thu Jan 28 07:58:29 2021
> 2021-01-28 07:58:29.139244 E  decoding error End of file (-541478725)
> EDIT - crash

I don't know precisely how master relates to the versions in the mac 
build, but (again) this may be relevant.  I started getting crashes in 
the cutlist editor after a bunch of commits to master in late October. 
The crashes went away after the commit that I mentioned earlier, but 
editing still had occasional 20-second hangups that happened not 
randomly, but unpredictably.

It's too early to be certain, but after another bunch of commits 
yesterday I have not seen any of these hangups.  Perhaps the 
'UIButtonList' was involved again.  (Thanks, Mark_K)  That's in Fedora 
32.  Unfortunately most of my recordings have been on  my el7 system, 
for which I can't now build because of the taglib bump the day before...

Back to the seektable:  I find the 'commflag --rebuild' recipe usually 
reliable, but I don't think it will repair defective files, and it 
doesn't regenerate seektables for DVB-T radio or, iirc, other formats 
such as mkv or mp4.

John P

More information about the mythtv-users mailing list