[mythtv-users] icons

John Pilkington johnpilk222 at gmail.com
Sat Jan 16 13:10:11 UTC 2021


On 16/01/2021 11:12, James Linder wrote:
> 
> 
>> On 16 Jan 2021, at 7:02 pm, David Watkins <watkinshome at gmail.com> wrote:
>>
>>
>>
>>
>>
>> Slowly and without any logic or sense icons are starting to appear and indeed 7 mate is showing it's icon.
>> Still no sense here (full listing)
>>
>> [sandypit] /home/jam [1001]% ll .mythtv/channels/
>> total 2680
>> -rw-r--r-- 1 jam users    226 Jan 12 18:14 180px-ABC3_logo.png
>> -rw-r--r-- 1 jam users  97032 Jan 13 10:43 4me_au.png
>> -rw-r--r-- 1 jam users 126018 Jan 13 10:43 7mate.png
>> -rw-r--r-- 1 jam video   3330 Jan 13 10:19 7mate.png.0x57.png
>> -rw-r--r-- 1 jam users  68214 Jan 13 10:42 7network_au.png
>> -rw-r--r-- 1 jam users  61136 Jan 13 10:43 7network_au_two.png
>> -rw-r--r-- 1 jam users  59156 Jan 13 10:43 7network_hd.png
>> -rw-r--r-- 1 jam users 307580 Jan 13 10:43 abc1_au.png
>> -rw-r--r-- 1 jam users 204166 Jan 13 10:43 abc3_au.png
>> -rw-r--r-- 1 jam users  78540 Jan 13 10:47 abc_hd_au.png
>> -rw-r--r-- 1 jam users 119257 Jan 13 10:43 abc_news_24_au.png
>> -rw-r--r-- 1 jam users  18461 Jan 12 18:14 abc-news-24.png
>> -rw-r--r-- 1 jam users   3685 Jan 12 18:14 channel_9_mm.png
>> -rw-r--r-- 1 jam users  79635 Jan 13 10:42 eleven_au.png
>> -rw-r--r-- 1 jam users  17667 Jan 12 18:14 eleven.png
>> -rw-r--r-- 1 jam users   5848 Jan 12 18:14 fresh_us.png
>> -rw-r--r-- 1 jam users 320188 Jan 13 10:43 national_indigenous_tv.png
>> -rw-r--r-- 1 jam users   5732 Jan 12 18:14 one_ca.png
>> -rw-r--r-- 1 jam users    168 Jan 12 18:14 sbs861c4b17d8fc1856b814.png
>> -rw-r--r-- 1 jam users   4595 Jan 12 18:14 sbs_au_hd.png
>> -rw-r--r-- 1 jam users   4797 Jan 13 10:51 sbs_one_au.png
>> -rw-r--r-- 1 jam users   3948 Jan 13 10:50 sbs_plus.png
>> -rw-r--r-- 1 jam users   6221 Jan 12 18:14 sbs_two_au.png
>> -rw-r--r-- 1 jam users  17955 Jan 12 18:14 seven-mate.png
>> -rw-r--r-- 1 jam users  10980 Jan 12 18:14 seven-two.png
>> -rw-r--r-- 1 jam users 332790 Jan 13 10:42 ten_network_au.png
>> -rw-r--r-- 1 jam users   4773 Jan 13 10:49 topv_food_channel.png
>> -rw-r--r-- 1 jam users 712552 Jan 13 10:44 tvsn_au.png
>> -rw-r--r-- 1 jam users   6210 Jan 12 18:14 west_television.png
>>
>>
>>
>> Have you restarted your backend recently?  Certainly that seems to trigger creation of the 0x57 files for me.
>>
>> I suspect that  mythfilldatabase might be involved in getting icons to appear as well?  - but I haven't tested that theory
>>
>> I'm running a combined BE/FE that shuts down between recordings, so I get plenty of restarts, and I run mythfilldatabase every day.
> 
> I think you are correct about mythfilldatabase, that would explain 'sporadically'
> I have restarted the backend, will try again since I have done lots of fiddling meantime.
> James

My earlier posts had been about my el7 build, where an icon scan 
succeeded and icons appeared in the frontend EPG.

I have now done a similar icon scan on the Fedora box.  Again the 
frontend EPG showed them, but there were no 0x57 files in 
~/.mythtv/channels.  Then I looked at the EPG in the web interface;  the 
icons appeared, and so did the 0x57 files.

The frontend log has a warning when it first needs to show an icon:

Qt: libpng warning: iCCP: known incorrect sRGB profile

or sometimes adds that the profile matches sRGB but it's writing iCCP 
instead.

The leanfront app on my firestick 4k shows the icons too - and (switch 
thread) most of my recordings now give very smooth playback on that. 
Check on the rolling credits.  One mpeg2 multiplex still gives problems 
there, apparently because the timestamp/GOP configuration is different. 
ProjectX doesn't handle it, at least in default mode, and ffmpeg sees it 
as bottom-frame-first.  Sony movies...




More information about the mythtv-users mailing list