[mythtv-users] Problem building fixes/31 from source on gentoo

Douglas Paul doug at bogon.ca
Fri Jan 15 17:54:22 UTC 2021


On Thu, Jan 14, 2021 at 05:29:36PM -0600, mythtv wrote:
> I'm building fixes/31 from source on gentoo. It compiles and install but 
> when I run, it says:
> mythfrontend: error while loading shared libraries: libdav1d.so.4: 
> cannot open shared object file: No such file or directory
> I originally had dav1d installed but it was version 0.8.0 which included 
> libdav1d.so.5. I tried to create a symlink of libdav1d.so.4 to  the 
> version 5 files but it complained about missing symbols.  I then 
> uninstalled dav1d and reconfigured and the output shows:
> libaom   (AV1)            yes
> libdav1d (AV1)            no
> but I still get the error when I try to launch mythfrontend.

When I have this sort of problem, it is because 'make clean' doesn't
always clean up everything. You might want to find and remove all .o and
.so files in your build tree.

If you have a git repo, you can also do 'git clean -f -dx' but make sure
you save anything you might want to keep, such as config.log, if you use
that to track your configure options.

Hope that helps,

Douglas Paul

More information about the mythtv-users mailing list