[mythtv-users] mac build

John Hoyt john.hoyt at gmail.com
Sun Feb 7 12:47:41 UTC 2021

> I ran my fe normally to watch the news
> /Applications/Mythfrontend.app/Contents/MacOS/mythfrontend
> dyld: Library not loaded: /opt/local/lib/libjpeg.9.dylib
>   Referenced from:
> /Applications/Mythfrontend.app/Contents/Frameworks/QtWebKit.framework/Versions/5/QtWebKit
>   Reason: image not found
> /Applications/Mythfrontend.app/Contents/MacOS/mythfrontend: line 15:   401
> Abort trap: 6           ./mythfrontend.real $@
> I'll like my wounds, and re-install macos, but the bundle reffering to a
> macports dylib looks wrong.

Was this the version you downloaded, previously built yourself, or tried to
build providing this error?

If it's the downloaded version, that's a head scratcher.

If it's a previous built version - there could be a host of problems
depending on how old it was and if the version had all of the libraries
bundled correctly.

Reinstalling macOS is a bit extreme.  I usually start with removing
macports and reinstalling that in case macports messed up the underlying


BTW - when you reinstall macports, make sure to switch it to git for the
ports tree. You'll get the updated ports faster.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mythtv.org/pipermail/mythtv-users/attachments/20210207/9d5c2d62/attachment.htm>

More information about the mythtv-users mailing list