[mythtv-users] USB-UIRT failing with kernel 5.8

Mary Strimel mary.strimel at gmail.com
Wed Apr 21 22:58:45 UTC 2021

I've already written to the lirc mailing list without success, so I'm
hoping someone here will be able to help. I have a USB-UIRT IR
receiver/blaster. It worked fine under LInux Mint 20 / kernel 5.4 to
support channel changing in myth. I just built a new computer and it
requires Linux Mint EDGE to support my AMD integrated graphics. This
version has me running kernel 5.8, and I think that is where the problem
comes in.

dmesg says the following about my device:

[185823.887376] usb 3-2: new full-speed USB device number 4 using xhci_hcd
[185824.058241] usb 3-2: New USB device found, idVendor=0403,
idProduct=f850, bcdDevice= 6.00
[185824.058245] usb 3-2: New USB device strings: Mfr=1, Product=2,
[185824.058246] usb 3-2: Product: USB-UIRT
[185824.058248] usb 3-2: Manufacturer: FTDI
[185824.063338] ftdi_sio 3-2:1.0: FTDI USB Serial Device converter detected
[185824.063380] usb 3-2: Detected FT232RL
[185824.071436] usb 3-2: FTDI USB Serial Device converter now attached to

I don't recall the "FTDI" being included before, so for starters, it would
be great if someone could check me on this.

The lirc docs say that (exactly one) entry should be created in
/sys/class/rc, and I used to have such an entry in my old system. However,
my new system shows nothing. This seems like a bad sign, as if there is no
remote control device visible to the kernel.

I have tried the following without success:

   - running "mode2" both as regular user and as root.  It states that
   /dev/ttyUSB0 cannot initialize

   - running lircd to explicitly give it the driver --driver=/uirt2_raw
   (this is the driver I used to successfully use) and the device
   --device=/ttyUSB0.  Again, efforts to use the device fail to initialize
   - changing the permissions on /ttyUSB0 and making them as broad as
   possible, then re-running the above. Nothing works.

Does anyone have this device working with kernel 5.8? or alternatively can
provide a guess as to how/why a kernel would drop this support, and how to
fix?  Is it possible that I need to use a different lirc driver now (is
that even a thing?)

I would even be happy just to know how to research whether to roll back my
kernel to an earlier version that supports this device, provided it also
supports my AMD integrated renoir graphics. I've tried poking around on
kernel.org but it doesn't seem geared for that.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mythtv.org/pipermail/mythtv-users/attachments/20210421/c763e3c3/attachment.htm>

More information about the mythtv-users mailing list