[mythtv-users] Deleted Recordings Not Being Removed

Stephen Worthington stephen_agent at jsw.gen.nz
Tue Apr 20 19:05:20 UTC 2021

On Tue, 20 Apr 2021 07:25:03 -0700, you wrote:

>On 4/19/21 8:57 PM, Stephen Worthington wrote:
>> On Mon, 19 Apr 2021 15:33:22 -0700, you wrote:
>>> What log?  What command do I use to see it?
>> The typical place for the log is /var/log/mythtv, but it depends on
>> what version of Linux you are using.  The file is normally called
>> mythbackend.log, but that can vary too.  It also pays to look at the
>> system logs and the systemd journals.  In Ubuntu, look at
>> /var/log/syslog and run this command which shows you the latest
>> entries in the system journal:
>> journalctl -e
>> So what system are you running?
>> And I do remember a bug that was in an old version of MythTV that had
>> symptoms similar to what you are seeing.  But I can not remember what
>> version it was in - I think it was older than 0.28, but I can not be
>> sure at all.  It was fixed quite quickly at the time, so if you are on
>> 0.28-fixes, it would not be that bug.
>The logs showed evidence of permissions problems.  I looked at the files 
>in the recording directory and some were owned by mythtv and others by 
>jay.  I ran 'sudo chown mythtv:mythtv *' in the recording directory and 
>tried the Deleted Recordings -> Playlist -> Delete technique again.  It 
>then appeared as if mythtv was now deleting the recordings (yeah).
>However, things are still broken somehow.  The 'mythbackend 
>--printexpire --quiet' command now shows just 7 recordings (the 7 I 
>watched and deleted last night).  This is expected.  The frontend 
>Deleted Recordings group also only has these same 7 recordings in it.  
>But the mythweb backend status still shows over 500GB of deleted 
>recordings remaining to be deleted.  The actions (above) resulted in 
>deleting about 260GB, but according to mythweb backend status, there is 
>still 570GB left to go.  How do I get mythtv to delete these deleted 
>Disk Usage Summary:
>  * Total Disk Space:
>      o Total Space: 3,813,582 MB
>      o Space Used: 3,302,627 MB
>      o Space Free: 510,955 MB
>      o Space Available After Auto-expire: 1,085,714 MB
>          + Space Used by LiveTV: 0 MB
>          + Space Used by Deleted Recordings: 574,759 MB
>          + Space Used by Auto-expirable Recordings: 0 MB

Give it some time to delete the recordings - look again in a few hours
and see if they have been deleted.  Depending on your settings,
deleting a recording can take a while.  And listen to your hard drives
- if they are active but no recordings are in progress, then deletes
are probably happening.  And if I remember similar problems in the
past correctly, restarting the backend is worth trying now that you
have fixed the ownership.  The delete processing will be restarted
when mythbackend is restarted.

Did you also check the permissions on the recording files?  If they do
not have write permission and write permission on the directory, then
deletes will fail.

I believe that recordings being deleted are marked with the
deletepending flag, so this query may show useful information:

sudo mysql
use mythconverg;
select chanid,starttime,title,deletepending from recorded where
deletepending!=0 order by starttime;

More information about the mythtv-users mailing list