[mythtv-users] 2 recordings failed at the same time

Jim Abernathy jfabernathy at gmail.com
Mon Oct 26 10:01:56 UTC 2020

On 10/25/20 9:27 PM, Jay Harbeston wrote:
>> On Oct 25, 2020, at 9:18 PM, James Abernathy <jfabernathy at gmail.com 
>> <mailto:jfabernathy at gmail.com>> wrote:
>> I rarely have any issues with my production mythtv backend v31 on 
>> Ubuntu 20.04. However this evening I tried to watch a recording that 
>> had just started recording about 20 minutes earlier. The title 
>> changed to a smaller text font and when I tried to select it to view 
>> I got an error about the recording not ready to view.  I had this 
>> issue with both recordings that were started at 7PM. Since I had a 
>> number of recordings that were to start at 8pm. I just rebooted and 
>> hoped that would fix things for the new recordings coming up. So the 
>> 7pm recordings are lost, but I exported the backend log around the 
>> time I had the problem to see if anyone can spot a problem that needs 
>> to be fixed on my system or in general. I'm running:
>> v31.0+fixes.202010122044.eb3c84de5f~ubuntu20.04.1
>> My tuner is a Hauppauge WinTV quadHD PCIe card.
>> log file on pastebin
>> https://pastebin.com/5CLrHP5D
> I see a lot of permission denied errors in the log, might be a hint there.
> Regards!

My log file has always been sprinkled with these 2 Permission denied 

/Oct 25 19:00:23 mythbuntu mythpreviewgen[57623]: mythpreviewgen[57623]: 
I CoreContext platforms/mythpowerdbus.cpp:530 (AcquireLock) PowerDBus: 
Failed to delay sleep,shutdown: Permission denied/
Oct 25 19:00:23 mythbuntu mythpreviewgen[57623]: mythpreviewgen[57623]: 
I CoreContext platforms/mythpowerdbus.cpp:360 (DeviceAdded) PowerDBus: 
Added UPower.Device '/org/freedesktop/UPower/devices/ups_hiddev0'
Oct 25 19:00:23 mythbuntu mythpreviewgen[57623]: mythpreviewgen[57623]: 
I CoreContext mythpower.cpp:348 (PowerLevelChanged) Power: On AC power
Oct 25 19:00:23 mythbuntu mythpreviewgen[57623]: mythpreviewgen[57623]: 
I CoreContext mythpower.cpp:131 (Init) Power: Supported actions: None
/Oct 25 19:00:23 mythbuntu mythpreviewgen[57623]: mythpreviewgen[57623]: 
E CoreContext main.cpp:77 (preview_helper) Setting priority failed.//
//eno: Permission denied (13)/

However this system has recorded gigabytes of programs while these 
errors continue to accumulate.

Not sure what they mean.

Yesterday I always had a couple of football games being recorded but it 
wasn't until 7PM with the start of 2 new recordings that I had a problem 
of nothing being written to a file.

The only thing new yesterday was frontend related. I just built a new 
x86_64 frontend with an Nvidia GT1030 gfx card on Archlinux KDE Plasma. 
When I built mythtv I only configured the frontend and it worked fine. 
However it was v0.31-118 and my backend is on Ubuntu is 
v0.31-202010122044. Both the most current v31 releases. I was using this 
frontend to view all recordings yesterday.

My backend was built about as standard as you could get from an Ubuntu 
point of view, nothing weird.

It's what I've done before and has been recording fine since July when I 
did the most recent complete rebuild. FWIW, I documented it here: 

I checked this morning and all my recordings since the reboot around 
7:30pm last night have been fine.

Jim A

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mythtv.org/pipermail/mythtv-users/attachments/20201026/06357688/attachment.htm>

More information about the mythtv-users mailing list