[mythtv-users] Remote frontend connection problems

Bill Meek keemllib at gmail.com
Mon Oct 19 02:58:51 UTC 2020

On 10/18/20 8:38 PM, Mary Strimel wrote:
> hi, 
> I have freshly installed mythtv system on my Linux Mint PC. I installed the available packages from my distro, myth version 31. 
> The local frontend works fine. However, the frontend that I installed on my Android TV -- also version 31 -- is unable to connect. At first it
> saw the database and was unable to connect to it. After trying some of the fixes I read about online, now it doesn't see the database at all. 
> Here are the things I've tried:
> 1. went to mythbackend-setup and set the IP address to my real address instead of
> 2. verified that the PIN for remote logon is set to 0000
> 3. verified that the mysql password on the Android is the same as the one found in /home/mythtv/.mythtv/config.xml
> 4. Attempted to tell sql to allow the remote connection.
>   A. At first I used the command 
> "grant all on mythconverg.* to 'mythtv'@'%' identified by 'mypassword';"
> then I got an error because apparently that command is now deprecated. 
> B. So I tried GRANT ALL ON mythconverg.* TO mythtv at localhost IDENTIFIED BY "mythtv" PASSWORD "mypassword" which did not report an error, but
> also didn't give any feedback. In fact it made the mysql prompt look funny, so I'm assuming it was unhelpful?

If you're running mysql (as opposed to mariadb), and it's version 8.x
see: https://code.mythtv.org/cgit/mythtv/tree/mythtv/database/mc.sql
for the proper SQL. These commands won't work on mariadb below 10.3.

> 5. I then went to /etc/mysql/my.cnf. According to the docs I should be commenting out a particular line regarding networking. However, my file
> didn't have those lines. It did not have sections either, like other peoples' seem to have. It just had two lines that start with "!includedir".
> I didn't change anything there.

Making changes to files under the 2nd includedir's path is good. It will be used after
the 1st. Just be sure the file is alpha numerically last (so any changes won't be
undone by changes in some other file.)

If changes are made to /etc/mysql/conf.d/mythtv.cnf (and the like), then
restart mysql then try the command above.

> 6. As a last resort I went to /etc/mysql/conf.d/mythtv.cnf and changed the first line to "bind-address=" [my IP].  I think this
> last step might have been wrong.

Probably OK.

> What else do I need to do to connect my frontend? Should I undo things I tried above?
> Thank you!
> Mary

If this doesn't work, then mythtv won't (I don't know if it's available
on the Android but you could try it from the backend host):

    mysql --user=mythtv --password=<from config.xml> --host=<hostname or IP of backend> mythconverg

    ^^^ assumes that the backend also has the SQL server running - which is likely.


More information about the mythtv-users mailing list