[mythtv-users] lircd unreliable after Ubuntu upgrade 16.04 > 18.04

Stephen Worthington stephen_agent at jsw.gen.nz
Wed Jun 24 14:50:20 UTC 2020

On Wed, 24 Jun 2020 07:37:56 -0400, you wrote:

>Stephen Worthington <stephen_agent at jsw.gen.nz> writes:
>> On Tue, 23 Jun 2020 22:25:21 -0400, you wrote:
>>>Stephen Worthington <stephen_agent at jsw.gen.nz> writes:
>>>> On Fri, 5 Apr 2019 19:20:13 -0700, you wrote:
>>>> Looks like that was my fault.  I must have used my Windows editor to
>>>> update the changelog in the file and forgot to tell it to save it with
>>>> Unix line endings.  I have fixed it now.
>>>I just updated all machines to Mythtv v31 and a new frontend with 20.04
>>>installed. As far as you know will your script still work as the 18.04
>>>version? Ubuntu is giving a message that the lirc package is not setup
>>>Thanks for any input.
>> My script is 18.04 specific, and I have not tested it on 20.04.  I do
>> not know what, if any, problems lirc in 20.04 has.  I did try 20.04 in
>> VirtualBox when it was released, and found a showstopper bug in lirc,
>> but it had an easy workaround and I filed a bug report.  That bug was
>> supposed to have been fixed (I got notifications), but I never had the
>> time to check and see due to real life getting in the way.
>> I think the chances that all of my script is still needed are small.
>> The problems with lirc in 18.04 were never with lirc itself - if you
>> manually configured it properly, it would work.  The problems were
>> with the 18.04 package, which did not install all the needed library
>> files for the Python configuration tools, and did not install valid
>> configurations.  My impression was that the package install had only
>> been tested on a machine where the package had been developed, and
>> hence the problems with the package were masked by the presence of the
>> source code and the results of compiling that.
>> So, what is the message that you are now encountering?  If it is
>> something that was also in 18.04, I should be able to point you to the
>> bits of my script that would, with appropriate changes, fix it.
>The messages I am getting are as follows when I run your script:
>All prerequites are now in place, attempting to install the lirc Python 3 support...
>WARNING: Requirement '/usr/share/lirc/lirc-0.10.0.tar.gz' looks like a filename, but the file does not exist
>Processing /usr/share/lirc/lirc-0.10.0.tar.gz
>ERROR: Could not install packages due to an EnvironmentError: [Errno 2] No such file or directory: '/usr/share/lirc/lirc-0.10.0.tar.gz'
>Exited - doing final cleanup
>When I look in /usr/share/lirc, what I see is "lirc-0.10.1.tar.gz".
>I am guessing there is a new version and the name needs only to be
>changed, I hope. I did take a look at your script, but I was not 100%
>sure where that change needed to be made.
>I am hoping this is the only change that is needed.
>ubuntu 20.04 wants to install lirc-0.10.1-6.ubuntu1.1
>Thanks for your help.

Take a step back.  What problems are you having with lirc on 20.04?
Why do you think you need my script to fix things?  Does it give error
messages when you run lirc-setup?

More information about the mythtv-users mailing list