[mythtv-users] HDPVR intermittent failure

DryHeat122 dryheat122 at gmail.com
Sat Jul 25 15:44:16 UTC 2020


After successfully building this on my Ubuntu 16.04 box, I tried building
it again on my new 20.04 box. This time I got the following errors when
running make:

../../Common/EncoderDev/encoderDev_DXT.cpp: In destructor 'virtual
encoderDev_DXT_t::~encoderDev_DXT_t()':
../../Common/EncoderDev/encoderDev_DXT.cpp:13:2: error: 'wrapLogInfo' was
not declared in this scope; did you mean 'wrapLogError'?
   13 |  wrapLogInfo("encoderDev_DXT_t::~encoderDev_DXT_t()");
      |  ^~~~~~~~~~~
      |  wrapLogError
../../Common/EncoderDev/encoderDev_DXT.cpp: In member function 'virtual
bool encoderDev_DXT_t::init()':
../../Common/EncoderDev/encoderDev_DXT.cpp:24:2: error: 'wrapLogInfo' was
not declared in this scope; did you mean 'wrapLogError'?
   24 |  wrapLogInfo("encoderDev_DXT_t::init()");
      |  ^~~~~~~~~~~
      |  wrapLogError
../../Common/EncoderDev/encoderDev_DXT.cpp: In member function 'virtual
bool encoderDev_DXT_t::startCapture()':
../../Common/EncoderDev/encoderDev_DXT.cpp:183:2: error: 'wrapLogInfo' was
not declared in this scope; did you mean 'wrapLogError'?
  183 |  wrapLogInfo("encoderDev_DXT_t::startCapture()");
      |  ^~~~~~~~~~~
      |  wrapLogError
../../Common/EncoderDev/encoderDev_DXT.cpp: In member function 'virtual
bool encoderDev_DXT_t::stopCapture()':
../../Common/EncoderDev/encoderDev_DXT.cpp:190:2: error: 'wrapLogInfo' was
not declared in this scope; did you mean 'wrapLogError'?
  190 |  wrapLogInfo("encoderDev_DXT_t::stopCapture()");
      |  ^~~~~~~~~~~
      |  wrapLogError
make[1]: *** [<builtin>: encoderDev_DXT.o] Error 1
make[1]: Leaving directory
'/home/steve/src/Hauppauge/hauppauge_hdpvr2_157321_patched_2016-09-26/TestApp/build-ADV7842'
make: *** [Makefile:2: all] Error 2

How to fix?  Change wrapLogInfo to wrapLogError as suggested?

On Wed, Jul 22, 2020 at 5:47 PM DryHeat122 <dryheat122 at gmail.com> wrote:

> That was it...I had the wrong group in the config file.  Now Myth no
> longer says the recorder is offline, the recordings are merely failing.  So
> that's progress?
>
> I think it might be failing because my channel changer is failing, and
> that is because my FireWire seems to be hosed. plugreport returns nothing,
> firewire_tester can't connect to any port.
>
> This is bizarre because FireWire and the channel changer was working until
> I started the recorder changeover this morning. Can you think of any reason
> the HDPVR2 software would affect FireWire?
>
> On Wed, Jul 22, 2020, 5:31 PM John P Poet <jppoet at gmail.com> wrote:
>
>> On Wed, Jul 22, 2020 at 5:12 PM DryHeat122 <dryheat122 at gmail.com> wrote:
>>
>>>
>>>
>>> On Wed, Jul 22, 2020 at 1:07 PM DryHeat122 <dryheat122 at gmail.com> wrote:
>>>
>>>>
>>>>
>>>> On Wed, Jul 22, 2020 at 9:44 AM DryHeat122 <dryheat122 at gmail.com>
>>>> wrote:
>>>>
>>>>> On Fri, Jul 10, 2020 at 4:12 AM John Hoyt <john.hoyt at gmail.com> wrote:
>>>>>
>>>>>> That is not for the inexperienced or faint of heart to install and
>>>>>>> configure. It scares me a little :-) I can't imagine what it was like to
>>>>>>> develop it!
>>>>>>>
>>>>>>
>>>>>> Configuration is actually not as scary as it looks at first.  Also,
>>>>>> it was quite worth it as I've found my colossus to work with higher
>>>>>> reliability and better quality than my HDPVR ever did.
>>>>>>
>>>>>> If you're running  Ubuntu - you can use the compiled binary on my
>>>>>> Launchpad ppa to skip the compile steps -
>>>>>> https://launchpad.net/~john-hoyt/+archive/ubuntu/hauppaugeusb
>>>>>>
>>>>>
>>>>> I decided to try this with my current Myth setup, and it looks like
>>>>> you don't have a version for Ubuntu 16.04.  So I did the compile myself.
>>>>> Everything was going great until the very end of the make and I got:
>>>>>
>>>>> g++ -g -c -Wall -std=c++11 -fdiagnostics-color -DBOOST_LOG_DYN_LINK
>>>>> -pthread -m64 -g -O3 -D_GNU_SOURCE -DDRIVER_BUILD -DHAUPPAUGE -DHCW_E5BDA
>>>>> `pkg-config --cflags libusb-1.0` -I.. -I./Hauppauge/Common
>>>>> -I./Wrappers/linux -I./Hauppauge/Common/FX2API
>>>>> -I./Hauppauge/Common/Rx/ADV7842 -I./Hauppauge/Common/Rx/ADV7842/RX
>>>>> -I./Hauppauge/Common/Rx/ADV7842/RX/LIB
>>>>> -I./Hauppauge/Common/Rx/ADV7842/RX/HAL
>>>>> -I./Hauppauge/Common/Rx/ADV7842/RX/HAL/4G
>>>>> -I./Hauppauge/Common/Rx/ADV7842/RX/HAL/4G/ADV7842/HAL
>>>>> -I./Hauppauge/Common/Rx/ADV7842/RX/HAL/4G/ADV7842/MACROS
>>>>> -I./Hauppauge/Common/Rx -I./Hauppauge/Common/EncoderDev
>>>>> -I./Hauppauge/Common/EncoderDev/HAPIHost
>>>>> -I./Hauppauge/Common/EncoderDev/HAPIHost/MChip `pkg-config --cflags
>>>>> libusb-1.0` ./Hauppauge/Common/Rx/audio_CS8416.cpp -o audio_CS8416.o
>>>>> ./Hauppauge/Common/Rx/audio_CS8416.cpp: In member function ‘bool
>>>>> audio_CS8416::DeviceIO::write(audio_CS8416::DeviceIO::Reg, const uint8_t*,
>>>>> size_t)’:
>>>>> ./Hauppauge/Common/Rx/audio_CS8416.cpp:173:39: error: ‘memcpy’ was not
>>>>> declared in this scope
>>>>>          memcpy(sendbuff + 1, data, len);
>>>>>                                        ^
>>>>> Makefile:61: recipe for target 'audio_CS8416.o' failed
>>>>> make: *** [audio_CS8416.o] Error 1
>>>>>
>>>>> What to do?
>>>>>
>>>>
>>>> I know next to nothing about cpp but I looked up the error, and it
>>>> seems to be caused by failure to declare #include <cstring>  I added that
>>>> to the top of  audio_CS8416.cpp and the build completed without errors.
>>>> Perhaps @JohnPoet would like to add this to the patches?
>>>>
>>>> Bottom line is that I now have it working.  Here are a couple of notes
>>>> for others trying this:
>>>>
>>>> When I first connected the HDPVR2 the light was rapid flashing blue
>>>> which according to docs means the machine can't "see" it.  When I tried to
>>>> record I got a repeated error:
>>>>
>>>> 2020-07-22T12:15:53.632520 ERRR <main> USBif.cpp:485 (controlMessage)
>>>> cannot send control message: No such device (it may have been disconnected)
>>>>
>>>> But after exiting the commsn the light was solid blue.  So I tried
>>>> again and got
>>>>
>>>> 2020-07-22T12:16:42.638981 CRIT <main> Logger.cpp:83
>>>> (setLogLevelFilter) Changing loglevel to NOTC
>>>> 2020-07-22T12:16:42.639124 CRIT <main> hauppauge2.cpp:347 (main)
>>>> Starting up
>>>> 2020-07-22T12:16:42.650486 CRIT <main> hauppauge2.cpp:360 (main)
>>>> Initializing [Bus: 2, Port: 6] E524-00-00ABAE4A
>>>> [long pause]
>>>> 2020-07-22T12:17:05.061224 CRIT <main> HauppaugeDev.cpp:392
>>>> (init_component) Cannot determine video mode.
>>>> 2020-07-22T12:17:05.362389 CRIT <main> hauppauge2.cpp:476 (main) Done.
>>>>
>>>> I discovered that the second to last error means there is no video
>>>> signal.  My cable box was off.  After turning it on I got a recording.
>>>>
>>>> For the devs, I did get one error:
>>>>
>>>> 2020-07-22T12:50:50.152620 ERRR <main> FX2Device.cpp:115 (I2CWriteRead)
>>>> I2C: Improper answer: status 07
>>>>
>>>> I don't know what it means, but it didn't prevent the recording.
>>>>
>>>> Thanks for all the help everyone!
>>>>
>>>
>>> Sooooo...having the HDPVR2 making test recordings, I set it up in Myth
>>> per the instructions in the https://github.com/jpoet/HauppaugeUSB.
>>> When I try to record anything, say from the program guide, it says
>>> "recorder offline" and I can find nothing in the frontend or backend logs
>>> about it.  However, the recorder shows the half-green lite indicating it's
>>> ready and I can still do test recordings.  How to  troubleshoot?
>>>
>>
>> My first guess would be a permission problem. The HD-PVR2
>> externalrecorder process will run as the same user as mythbackend. If that
>> user does not have permission to write its log file, for example, it will
>> fail.
>>
>> Run mythbackend with "-v channel,record", if you are not already. The
>> mythbackend log should show the reason for the error.
>>
>> John
>> _______________________________________________
>> mythtv-users mailing list
>> mythtv-users at mythtv.org
>> http://lists.mythtv.org/mailman/listinfo/mythtv-users
>> http://wiki.mythtv.org/Mailing_List_etiquette
>> MythTV Forums: https://forum.mythtv.org
>>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mythtv.org/pipermail/mythtv-users/attachments/20200725/6d90774a/attachment.htm>


More information about the mythtv-users mailing list