[mythtv-users] HDPVR intermittent failure

DryHeat122 dryheat122 at gmail.com
Wed Jul 22 20:07:58 UTC 2020

On Wed, Jul 22, 2020 at 9:44 AM DryHeat122 <dryheat122 at gmail.com> wrote:

> On Fri, Jul 10, 2020 at 4:12 AM John Hoyt <john.hoyt at gmail.com> wrote:
>> That is not for the inexperienced or faint of heart to install and
>>> configure. It scares me a little :-) I can't imagine what it was like to
>>> develop it!
>> Configuration is actually not as scary as it looks at first.  Also, it
>> was quite worth it as I've found my colossus to work with higher
>> reliability and better quality than my HDPVR ever did.
>> If you're running  Ubuntu - you can use the compiled binary on my
>> Launchpad ppa to skip the compile steps -
>> https://launchpad.net/~john-hoyt/+archive/ubuntu/hauppaugeusb
> I decided to try this with my current Myth setup, and it looks like you
> don't have a version for Ubuntu 16.04.  So I did the compile myself.
> Everything was going great until the very end of the make and I got:
> g++ -g -c -Wall -std=c++11 -fdiagnostics-color -DBOOST_LOG_DYN_LINK
> `pkg-config --cflags libusb-1.0` -I.. -I./Hauppauge/Common
> -I./Wrappers/linux -I./Hauppauge/Common/FX2API
> -I./Hauppauge/Common/Rx/ADV7842 -I./Hauppauge/Common/Rx/ADV7842/RX
> -I./Hauppauge/Common/Rx/ADV7842/RX/LIB
> -I./Hauppauge/Common/Rx/ADV7842/RX/HAL
> -I./Hauppauge/Common/Rx/ADV7842/RX/HAL/4G
> -I./Hauppauge/Common/Rx/ADV7842/RX/HAL/4G/ADV7842/HAL
> -I./Hauppauge/Common/Rx/ADV7842/RX/HAL/4G/ADV7842/MACROS
> -I./Hauppauge/Common/Rx -I./Hauppauge/Common/EncoderDev
> -I./Hauppauge/Common/EncoderDev/HAPIHost
> -I./Hauppauge/Common/EncoderDev/HAPIHost/MChip `pkg-config --cflags
> libusb-1.0` ./Hauppauge/Common/Rx/audio_CS8416.cpp -o audio_CS8416.o
> ./Hauppauge/Common/Rx/audio_CS8416.cpp: In member function ‘bool
> audio_CS8416::DeviceIO::write(audio_CS8416::DeviceIO::Reg, const uint8_t*,
> size_t)’:
> ./Hauppauge/Common/Rx/audio_CS8416.cpp:173:39: error: ‘memcpy’ was not
> declared in this scope
>          memcpy(sendbuff + 1, data, len);
>                                        ^
> Makefile:61: recipe for target 'audio_CS8416.o' failed
> make: *** [audio_CS8416.o] Error 1
> What to do?

I know next to nothing about cpp but I looked up the error, and it seems to
be caused by failure to declare #include <cstring>  I added that to the top
of  audio_CS8416.cpp and the build completed without errors.
Perhaps @JohnPoet would like to add this to the patches?

Bottom line is that I now have it working.  Here are a couple of notes for
others trying this:

When I first connected the HDPVR2 the light was rapid flashing blue which
according to docs means the machine can't "see" it.  When I tried to record
I got a repeated error:

2020-07-22T12:15:53.632520 ERRR <main> USBif.cpp:485 (controlMessage)
cannot send control message: No such device (it may have been disconnected)

But after exiting the commsn the light was solid blue.  So I tried again
and got

2020-07-22T12:16:42.638981 CRIT <main> Logger.cpp:83 (setLogLevelFilter)
Changing loglevel to NOTC
2020-07-22T12:16:42.639124 CRIT <main> hauppauge2.cpp:347 (main) Starting up
2020-07-22T12:16:42.650486 CRIT <main> hauppauge2.cpp:360 (main)
Initializing [Bus: 2, Port: 6] E524-00-00ABAE4A
[long pause]
2020-07-22T12:17:05.061224 CRIT <main> HauppaugeDev.cpp:392
(init_component) Cannot determine video mode.
2020-07-22T12:17:05.362389 CRIT <main> hauppauge2.cpp:476 (main) Done.

I discovered that the second to last error means there is no video signal.
My cable box was off.  After turning it on I got a recording.

For the devs, I did get one error:

2020-07-22T12:50:50.152620 ERRR <main> FX2Device.cpp:115 (I2CWriteRead)
I2C: Improper answer: status 07

I don't know what it means, but it didn't prevent the recording.

Thanks for all the help everyone!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mythtv.org/pipermail/mythtv-users/attachments/20200722/1187b833/attachment.htm>

More information about the mythtv-users mailing list