[mythtv-users] v31 - MacOS Playback - Quarter Screen Issue on Retina - Resolved

jam at tigger.ws jam at tigger.ws
Mon Jul 13 12:47:18 UTC 2020

> On 13 Jul 2020, at 5:53 pm, John Hoyt <john.hoyt at gmail.com> wrote:
> John did not go well for me.
> I installed python38 from macports
> Since it core dumped I ran in in a term
> James,
> That stinks.  I have no clue what could cause the segfault as this latest build only copies in additional python components.  If the older version is working for you - stick with it until the OSD issue gets resolved.  
> Did MacOS generate a crash report?  If so, can you mine it for the culprit error message / dylib or application.
> Was installing python38 the only change you made to your system?  If so - try removing it and running
> Also - are you saying the metadata was working on your system before you installed python38????  I had assumed (clearly incorrectly) that you had it installed after you were trying to compile, as this was not the case, can you describe your runtime setup (version of MacOS, version of Xcode, what ports if any are installed)?  We're chasing a strange gremlin with the metadata grabber not working for Steve - so there's probably a very subtle difference in both of your configurations that may give us a hint to solving the riddle.

John from my building attemps I surely had python38 installed. MythFrontend-31-intel-10.13.6-v31-3ef7db67fe.1-with-plugins.dmg does grab meta data, does work but has no OSD. The OSD is more important than the grabbing (I use alinux frontend to do that) so I'm using an even older version:
fixes/31 [v31.0-40-gce23a0225f]
3ef7db67fe does work still, just the latest build coredumps.

So to get the trace info for you I ran it and --- it worked!
Careful check of the git no says it is.the same. I downloaded once only so not a dl problem. I posted a sig 11 so I'm not dreaming. Will try using and see what happens (but the OSD is a biggie so I may break.


More information about the mythtv-users mailing list