[mythtv-users] 'Recording Rule does not exist' - new problem. Ubuntu 18.04, Mythtv 31

PlainFaceBoy plainfaceboy at hotmail.com
Mon Jul 6 13:15:58 UTC 2020

On Mon, Jun 29, 2020 at 2:18 PM PlainFaceBoy
>>> wrote:
>>>> >> Hi - I'm running Ubuntu 18.04 and Mythtv 31 (fresh install), 
>>>> previous
>>>> >> versions working fine and 31 no different. I've got 100's of
>>>> >> 'recordings' and 'videos' going gack around 10 years.
>>>> >> Just recently I seem to have lost the recording schedule info for
>>>> >> most of my recordings. When I hit E, or use M and edit recording
>>>> >> schedule I get a 'recording rule does not exist' message.
>>>> >> I can edit the metadata, but not the recording rule. This seems to
>>>> >> means that I cannot edit the covers, or fanart if I want to.
>>>> >>
>>>> >> I've not been through them all, but it looks like the oldest
>>>> >> recordings (pre 2013) still have the recording info in, but as 
>>>> far as
>>>> >> I can tell nothing since. All the videos are of course fine and 
>>>> I can
>>>> >> edit artwork as normal. In the recordings screen, they all still 
>>>> show
>>>> >> the recording date, and artwork is still present.
>>>> >>
>>>> >> I've tried restoring to the oldest database backup I have (about a
>>>> >> month ago) when I'm pretty sure everything was working, but I still
>>>> >> have the issue.
>>>> >>
>>>> >> Does anyone know why this might have happened?
>>>> >> I've done a few updates recently - might they be the cause?
>>>> >> I would like to fix this if I can, so any help greatly appreciated.
>>> You may want to check the consistency of your database. There is a 
>>> script
>>> in mythtv to do it, but I cannot find it on my system. Mysql will do 
>>> it as
>>> well:
>>> mysqlcheck -h mysql -u mythtv -pmythtv mythconverg
>>> The -h is the hostname of your mythconverg database, probably 
>>> localhost for
>>> most. -u and -p are the username and passwords from 
>>> /etc/mythtv/config.xml
>> In Ubuntu:
>> /usr/share/doc/mythtv-backend/contrib/maintenance/optimize_mythdb.pl
>> but it should also be installed as:
>> /etc/cron.daily/optimize_mythdb
>> so that it gets run daily. Without regular checks, errors in the 
>> database can build on each other until a table is unfixable. If the 
>> first error that happens gets fixed by the daily check, that normally 
>> does not happen. If your MythTV box crashes or is reset without being 
>> shut down (eg power cut), you should also run optimize_mythdb as soon
>> as possible after it reboots as any table in the database that was 
>> being written to at that time may be damaged or crashed.
> I have run optimize now and then (I used to have a daily job but have 
> forgotten to put back at re-installs) - but I tried that tonight, and 
> mysqlcheck. Both ran successfully but made no difference. All 
> recordings after a date some years back still have no recording rule. 
> For all the recordings with the missing recording rule, in the 'show 
> recording details' option under menu there is a 'recording rule' field 
> (typically a number eg 21, 39, etc). The older recordings that still 
> have the rule (and where I can edit the recording schedule) do not 
> show this field in the show recording details screen. Not sure if that 
> means anything.
> Is there any other way I can rebuild the database and fix this, 
> without risking making things worse?
Just following up my last question in case anyone can help? I've checked 
more recordings, and situation is as described. All recordings after a 
date some years ago say 'recording rule does not exist', but the info 
itself shows in the recordfings screen, and in recording info.
There is also a 'recording rule' field which lists a difeent number for 
each recording.
Is there any way I can get ix trhis so I can edit recording rules, and 
update covers/fan art etc?

Thanks for any help.

This email has been checked for viruses by Avast antivirus software.

More information about the mythtv-users mailing list