[mythtv-users] MariaDB 10.3.22 Database access with Master and Fedora 31

John Pilkington johnpilk222 at gmail.com
Thu Jul 2 18:05:19 UTC 2020

On 02/07/2020 18:33, Bill Meek wrote:
> On 7/2/20 11:29 AM, John Pilkington wrote:
>> I ran Master under Fedora 30 and was able to use local and remote 
>> frontends and DLNA.  During the upgrade to Fedora 31 the network 
>> address somehow got changed, and I have been struggling ever since 
>> with that system.
>> I'm using locally built rpms from GaryB's script, so some file 
>> locations differ from those used in the rpmfusion (or *buntu) builds.  
>> This only matters when trying to interpret posts referring to other 
>> systems.
>> Early on I re-ran the DB setup process using 
>> /usr/share/doc/mythtv/database/mc.sql, but that appears to have 
>> disabled network access to the DB. It's all about 'localhost'.  
>> mythtv-setup can't make persistent changes now, and frontend startup 
>> is unreliable. The commands suggested in the wiki to 'restrict by IP 
>> subnet' give a 'mistake in syntax'.
>> The thread below had possible updates involving ALTER but seemed to 
>> fade away without reaching a good conclusion.  Is there a version of 
>> mc.sql that would work?   Or any additional lines?   MariaDB 10.3.22
>> https://lists.gt.net/mythtv/users/629679#629679
>> Thanks,
>> John P
> Hi,
> Not sure what the full command is that's not working.
> You might cite the Wiki page that isn't working. I found one
> https://www.mythtv.org/wiki/Installing_MythTV_on_Fedora that
> was last updated in 2017.

In  https://www.mythtv.org/wiki/Database_Setup
The section below gave me the 'mistake in syntax' response

Finally, if you just want to restrict by IP subnet (in this example, the 
192.168.1. network):

     $ mysql -u root mythconverg
     mysql> create user "mythtv"@"192.168.1.%" identified by "mythtv";
     mysql> grant all on mythconverg.* to mythtv@"192.168.1.%";
     mysql> flush privileges;

> Here's the current mc.sql:
>    https://code.mythtv.org/cgit/mythtv/tree/mythtv/database/mc.sql

Yes, that's the one I used, with (IIUC) the equivalents of
mythtv-setup.real, mythbackend and mythfrontend.real.

> There were a couple of threads about the MySQL v8 changes that
> are reflected in the new mc.sql, so the issue was solved, but
> for *buntu packaging (for MariaDB and MySQL).

More information about the mythtv-users mailing list