[mythtv-users] Mythfrontend segmentatiion fault after MythTV rebuild (29.1-r1)

Tom Dexter digitalaudiorock at gmail.com
Wed Jun 19 14:39:57 UTC 2019

On 6/17/19, James Miller <gajs-f0el at dea.spamcon.org> wrote:
> Gentoo system whose main function is to run MythTV (combination FE/BE).
> Hardware is Liva-X. Recently MythTV got rebuilt on this system, triggered
> by an update to qtwebkit. After the rebuild I get a segmentation fault
> when trying to start the FE (BE starts and seems to run normally). I log
> output of the command mythfrontend.real to a file, and here is the tail
> end of the output:
> 2019-06-15 15:03:57.845100 I UI Screen Resolution: 1920 x 1081
> 2019-06-15 15:03:58.000746 W OpenGL: Could not determine whether Sync to
> VBlank is enabled.
> 2019-06-15 15:03:58.030155 I Trying the OpenGL 2.0 render
> 2019-06-15 15:03:58.033832 I OpenGL painter using existing OpenGL context.
> 2019-06-15 15:03:58.068301 I OpenGL2: GLSL supported
> 2019-06-15 15:03:58.068389 I OpenGL: OpenGL vendor : Intel Open Source
> Technology Center
> 2019-06-15 15:03:58.068409 I OpenGL: OpenGL renderer: Mesa DRI Intel(R)
> Bay Trail
> 2019-06-15 15:03:58.068422 I OpenGL: OpenGL version : 3.0 Mesa 18.3.6
> 2019-06-15 15:03:58.068437 I OpenGL: Max texture size: 16384 x 16384
> 2019-06-15 15:03:58.068448 I OpenGL: Max texture units: 8
> 2019-06-15 15:03:58.068461 I OpenGL: Direct rendering: Yes
> 2019-06-15 15:03:58.068498 I OpenGL: Extensions Supported: 1e1b
> 2019-06-15 15:03:58.068516 I OpenGL: PixelBufferObject support available
> 2019-06-15 15:03:58.085305 I OpenGL: Initialised MythRenderOpenGL
> 2019-06-15 15:03:58.283884 N Setting QT default locale to en_US
> libpng warning: iCCP: known incorrect sRGB profile
> libpng warning: iCCP: known incorrect sRGB profile
> 2019-06-15 15:03:58.909772 I MythUIWebBrowser: Loading css from -
> file:///usr/share/mythtv/themes/default/htmls/mythbrowser.css
> 2019-06-15 15:03:58.914018 I MythUIWebBrowser: enabling plugins
> Handling Segmentation fault
> There currently is no mythplugins package available under this distro, and
> I really never use those plugins anyway. Could absence of plugins somehow
> be causing a segfault? If so, what to do to remedy the situation?
> Scanning /var/log/mythtv/mythfrontend.x.x.log doesn't reveal anything to
> my fairly untrained eye. But there's a lot there and I may well have
> overlooked something. I could pastebin that if examining that content
> might help diagnose the issue.
> Things I've tried so far, to no avail. Tried an alternate WM (JWM instead
> of the usual evilwm). Downgrade of libpng (from 1.6.37 to 1.5.30) to see
> if libpng warning might be the source of the problem. Created a
> /usr/lib64/mythtv/plugins/ (empty) directory. Upgrade of current WM
> (1.0.1-rc1 to 1.1.1). None of those made any difference in whether I get
> the segfault when trying to start mythfrontend.
> Tips on restoring mythfrontend functionality on this system will be
> appreciated. Thanks.

I'm running 29.1 under Gentoo (on 32 bit x86). My situation is a bit
different however as I'm using my own ebuild without any qtwebkit at
all. Among other places I've described that here:


One thing that threw me immediately is the fact that you had any QT
update trigger a rebuild of MythTV at all. I was surprised to see that
the dependencies in the current portage mythtv-29.1-r1.ebuild require
rebuilds for minor version changes...that is for example:


My ebuild has all those set as:


That is, to not require a rebuild for a minor 5.x to 5.x update. My
understanding has always been that that's not necessary.

All that aside, I'm not sure what would cause that segfault, but is
certainly seems to be related to MythUIWebBrowser which, I believe,
actually is compiled in MythTV even with no plugins. However it's not
necessary. In my case without qtwebkit it's not in there at all, and I
see no trace of "MythUIWebBrowser" in my logs for example.

Since you're pretty much broken as it stands now, one possibility is
to try what I've done as described in that link. Unfortunately as
noted there it requires unmerging qtwebkit in order to work.
Summarized, that requires:

a. A version of the ebuild in your overlay with the
"dev-qt/qtwebkit:5" removed from COMMON.

b. Uninstalling qtwebkit before the build.

c. A patch for the MythTV configure script to allow the missing qtwebkit.

I've actually attached a patch that you can use. You just need to put
that under a directory /etc/portage/patches/media-tv/mythtv-29.1-r1
and that will do it.

A side note to that is that running MythTV systems without that
horrific qtwebkit monstrosity is awesome. If you decide to try, feel
free to reply with any questions!

-------------- next part --------------
A non-text attachment was scrubbed...
Name: mythtv-29.1-qtwebkit-disable.patch
Type: text/x-patch
Size: 952 bytes
Desc: not available
URL: <http://lists.mythtv.org/pipermail/mythtv-users/attachments/20190619/8b4365f4/attachment.bin>

More information about the mythtv-users mailing list