[mythtv-users] Mythfrontend segmentatiion fault after MythTV rebuild (29.1-r1)

James Miller gajs-f0el at dea.spamcon.org
Mon Jun 17 18:41:19 UTC 2019


Gentoo system whose main function is to run MythTV (combination FE/BE). 
Hardware is Liva-X. Recently MythTV got rebuilt on this system, triggered 
by an update to qtwebkit. After the rebuild I get a segmentation fault 
when trying to start the FE (BE starts and seems to run normally). I log 
output of the command mythfrontend.real to a file, and here is the tail 
end of the output:

2019-06-15 15:03:57.845100 I UI Screen Resolution: 1920 x 1081
2019-06-15 15:03:58.000746 W OpenGL: Could not determine whether Sync to 
VBlank is enabled.
2019-06-15 15:03:58.030155 I Trying the OpenGL 2.0 render
2019-06-15 15:03:58.033832 I OpenGL painter using existing OpenGL context.
2019-06-15 15:03:58.068301 I OpenGL2: GLSL supported
2019-06-15 15:03:58.068389 I OpenGL: OpenGL vendor : Intel Open Source 
Technology Center
2019-06-15 15:03:58.068409 I OpenGL: OpenGL renderer: Mesa DRI Intel(R) 
Bay Trail
2019-06-15 15:03:58.068422 I OpenGL: OpenGL version : 3.0 Mesa 18.3.6
2019-06-15 15:03:58.068437 I OpenGL: Max texture size: 16384 x 16384
2019-06-15 15:03:58.068448 I OpenGL: Max texture units: 8
2019-06-15 15:03:58.068461 I OpenGL: Direct rendering: Yes
2019-06-15 15:03:58.068498 I OpenGL: Extensions Supported: 1e1b
2019-06-15 15:03:58.068516 I OpenGL: PixelBufferObject support available
2019-06-15 15:03:58.085305 I OpenGL: Initialised MythRenderOpenGL
2019-06-15 15:03:58.283884 N Setting QT default locale to en_US
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
2019-06-15 15:03:58.909772 I MythUIWebBrowser: Loading css from - 
file:///usr/share/mythtv/themes/default/htmls/mythbrowser.css
2019-06-15 15:03:58.914018 I MythUIWebBrowser: enabling plugins
Handling Segmentation fault

There currently is no mythplugins package available under this distro, and 
I really never use those plugins anyway. Could absence of plugins somehow 
be causing a segfault? If so, what to do to remedy the situation?

Scanning /var/log/mythtv/mythfrontend.x.x.log doesn't reveal anything to 
my fairly untrained eye. But there's a lot there and I may well have 
overlooked something. I could pastebin that if examining that content 
might help diagnose the issue.

Things I've tried so far, to no avail. Tried an alternate WM (JWM instead 
of the usual evilwm). Downgrade of libpng (from 1.6.37 to 1.5.30) to see 
if libpng warning might be the source of the problem. Created a 
/usr/lib64/mythtv/plugins/ (empty) directory. Upgrade of current WM 
(1.0.1-rc1 to 1.1.1). None of those made any difference in whether I get 
the segfault when trying to start mythfrontend.

Tips on restoring mythfrontend functionality on this system will be 
appreciated. Thanks.


More information about the mythtv-users mailing list