[mythtv-users] MCE/HID remote double events

Zach Cutlip uid000 at gmail.com
Mon Jun 17 05:46:32 UTC 2019


On Sun, Jun 16, 2019 at 6:13 PM Greg Oliver <oliver.greg at gmail.com> wrote:
>
> On Sun, Jun 16, 2019 at 7:18 PM Zachary Cutlip <uid000 at gmail.com> wrote:
>>
>> Hello,
>>
>> I'm trying to set up an MCE remote using evdev, and I'm getting double events in Mythfrontend for every key fairly consistently; maybe 80% of the time.
>>
>> I've set up the remote from a combination of these two wiki articles:
>>
>> https://www.mythtv.org/wiki/HID_Remotes
>> https://www.mythtv.org/wiki/User_Manual:IR_control_via_evdev
>>
>> evtest usually doesn't report the extra event even when Mythtv does.
>>
>> I've even set repeat delay and period to really high values.
>>
>> For example, here's an instance where pressing "down" resulted in event, but 'evtest' didn't:
>> Testing ... (interrupt to exit)
>> Event: time 1560729712.782138, type 4 (EV_MSC), code 4 (MSC_SCAN), value 800f041f
>> Event: time 1560729712.782138, type 1 (EV_KEY), code 108 (KEY_DOWN), value 1
>> Event: time 1560729712.782138, -------------- SYN_REPORT ------------
>> Event: time 1560729712.888133, type 4 (EV_MSC), code 4 (MSC_SCAN), value 800f041f
>> Event: time 1560729712.888133, -------------- SYN_REPORT ------------
>> Event: time 1560729713.022172, type 4 (EV_MSC), code 4 (MSC_SCAN), value 800f041f
>> Event: time 1560729713.022172, -------------- SYN_REPORT ------------
>> Event: time 1560729713.294223, type 1 (EV_KEY), code 108 (KEY_DOWN), value 0
>> Event: time 1560729713.294223, -------------- SYN_REPORT ------------
>>
>> Here's ir-keytable output:
>>
>> Found /sys/class/rc/rc0/ (/dev/input/event8) with:
>>         Name: Media Center Ed. eHome Infrared Remote Transceiver (1784:0011)
>>         Driver: mceusb, table: rc-rc6-mce
>>         Supported protocols: rc-5 rc-5-sz jvc sony nec sanyo mce_kbd rc-6 sharp xmp
>>         Enabled protocols: rc-6
>>         bus: 3, vendor/product: 1784:0011, version: 0x0100
>>         Repeat delay = 10000 ms, repeat period = 10000 ms
>>
>> FIW the remote is a Logitech harmony 650 programmed as a Windows Media Center PC.
>>
>> Thanks in advance,
>> Zach
>>
>
> Long ago I had an issue like this and it was due to having multiple definitions in the lirc config file.  It is nothing that simple is it (hopefully)?
>
> -Greg
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://lists.mythtv.org/mailman/listinfo/mythtv-users
> http://wiki.mythtv.org/Mailing_List_etiquette
> MythTV Forums: https://forum.mythtv.org

Unfortunately, I don't think lirc has anything to do with the problem.
I have lirc completely disabled and am using evdev.


More information about the mythtv-users mailing list