[mythtv-users] BE3 - Issues with installation and database

Barry Martin barry3martin at gmail.com
Mon Jun 3 22:27:12 UTC 2019


Hi Stephen!

Owner (blank!) Create and delete
Group Mythtv Create and delete
	Others (nothing -never is) Access files

I’ve always seen ‘somebody’ (usually root or me) as owner.

I am not sure about how MythTV-lite installs on RPi, so I do not know
what the correct ownership should be.  But if the RPi is only being
used as a frontend, its backend should not be running, and it is the
backend that uses those files on the RPi.  The recording files the
frontend should be accessing are on BE3.

    Appears the problem was with the RPi’s config.xml. Frankly I was
    surprised when copying in the Backend’s file solved the Frontend
    connection issue. So much for me trying to look intelligent! <g>



stephen at mypvr:~/.mythtv$ <mailto:stephen at mypvr:~/.mythtv$> ll co*
-rw-rw-r-- 1 stephen stephen  629 May 26 05:06 config.xml
-rw-rw-r-- 1 stephen stephen 1038 Sep 20  2013 config.xml.crw-pvr
-rw-rw-r-- 1 stephen stephen  623 May  7  2016 config.xml.lith
-rw-rw-r-- 1 stephen stephen  629 May 26 05:06 config.xml.mypvr

    Well, of course on my Backend it’s not like that:


    barry at Backend-3:~$ ll co*

    ls: cannot access 'co*': No such file or directory


    barry at Backend-3:~/.mythtv$ cd /home/barry/.mythtv

    barry at Backend-3:~/.mythtv$ ll co*

    -rw-r--r-- 1 barry barry 599 Jun 3 10:14 config.xml

    -rw-r--r-- 1 barry barry 485 May 26 12:41 config.xml_before_link


    /etc/mythtv/

    barry at Backend-3:/etc/mythtv$ ll co*

    -rw-rw---- 1 mythtv mythtv 452 May 26 12:28 config.xml

    -rw-r----- 1 root root 454 May 14 10:26 config.xml_original

    barry at Backend-3:/etc/mythtv$



    barry at Backend-3:/etc/mythtv$ cd /home/mythtv/.mythtv

    barry at Backend-3:/home/mythtv/.mythtv$ ll co*

    lrwxrwxrwx 1 root root 22 May 12 17:59 config.xml ->
    /etc/mythtv/config.xml

    barry at Backend-3:/home/mythtv/.mythtv$


    I think my first got-it listing is the same as your’s
    (/home/barry/.mythtv)



Does BE3 have the mythweb package(s) installed? That might be why
http://192.168.0.3/mythweb  does not work.  Or there could be Apache
config problems, which would show up in the Apache log files.

    Apparently not installed. I don’t recall installing in the past, but
    that was years ago, plus things change. It looks like going to the
    port displays everything (and more!) the old systems’ mythweb displayed.

- -

    And yes, this is a slightly late reply: I’ll admit I was playing
    with the RPi Frontend now that we finally got it working (thank you
    thank you thank you!!). Wireless 5G almost works with a 1080i
    programme (I’m in the U.S. so referencing those standards): had some
    issues with Audio dropping out apparently due to the Video speeding
    up slightly because of the amount of data and dropped some. Did play
    around some with the GPU memory allocation. A programme from a
    station with 720p resolution was a lot better but still minor
    issues. A programme form a lower resolution substation (480i) played
    fine.


    Using a wired connection seems to solve the problem (100Mbps vs. ~52
    Mbps?). ...I may have to install an Ethernet connection one place
    here after all. All the current watch-TV positions are wired.


    Oh, Closed Captioning didn’t work on the RPi (does on the Backend)
    with or without the MPEG2 license; tried default of ToggleCC,
    ToggleCC608 (VBI CC), and ToggleCC708 (ATSC CC). May be an issue
    with MythTV Light as fairly certain works with the RPi (older non-5G
    capability) though pretty sure regular Myth on it.


    So looks like perhaps the next step is the mythexport/mythimport.


    Thanks!
    Barry



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mythtv.org/pipermail/mythtv-users/attachments/20190603/2ce3133e/attachment-0001.html>


More information about the mythtv-users mailing list