[mythtv-users] BE3 - Issues with installation and database

Barry Martin barry3martin at gmail.com
Sat Jun 1 16:08:17 UTC 2019

Hi Stephen!

Now the next thing to do is to check and see if the DroidSans.ttf you 
have found is actually a font file, or whether it is a link to somewhere 
else. So what does this command show:

*ll //usr/share/mythtv/fonts//**

    barry at Backend-3:~$ ll /usr/share/mythtv/fonts/*

    lrwxrwxrwx 1 root root 45 May 1 01:02
    /usr/share/mythtv/fonts/DroidSans-Bold.ttf ->

    lrwxrwxrwx 1 root root 44 May 1 01:02
    /usr/share/mythtv/fonts/DroidSansMono.ttf ->

    lrwxrwxrwx 1 root root 40 May 1 01:02
    /usr/share/mythtv/fonts/DroidSans.ttf ->

    lrwxrwxrwx 1 root root 52 May 1 01:02
    /usr/share/mythtv/fonts/DroidSerif-BoldItalic.ttf ->

    lrwxrwxrwx 1 root root 46 May 1 01:02
    /usr/share/mythtv/fonts/DroidSerif-Bold.ttf ->

    lrwxrwxrwx 1 root root 48 May 1 01:02
    /usr/share/mythtv/fonts/DroidSerif-Italic.ttf ->

    lrwxrwxrwx 1 root root 49 May 1 01:02
    /usr/share/mythtv/fonts/DroidSerif-Regular.ttf ->

    lrwxrwxrwx 1 root root 42 May 1 01:02
    /usr/share/mythtv/fonts/FreeMono.ttf ->

    lrwxrwxrwx 1 root root 46 May 1 01:02
    /usr/share/mythtv/fonts/FreeSansBold.ttf ->

    lrwxrwxrwx 1 root root 42 May 1 01:02
    /usr/share/mythtv/fonts/FreeSans.ttf ->

    lrwxrwxrwx 1 root root 36 May 1 01:02
    /usr/share/mythtv/fonts/Purisa.ttf ->

    lrwxrwxrwx 1 root root 73 May 1 01:02
    /usr/share/mythtv/fonts/texgyrechorus-mediumitalic.otf ->

    -rw-r--r-- 1 root root 39728 May 1 01:01
    '/usr/share/mythtv/fonts/Tiresias Infofont Bold.ttf'

    -rw-r--r-- 1 root root 44788 May 1 01:01
    '/usr/share/mythtv/fonts/Tiresias Infofont Italic.ttf'

    -rw-r--r-- 1 root root 42084 May 1 01:01
    '/usr/share/mythtv/fonts/Tiresias Infofont.ttf'

    barry at Backend-3:~$

    The first seven are red on guess a charcoal gray. Both sides of the
    arrow. (So according to my handy-dandy chart “symlink to
    non-existant file”

    The middle five the left side is a light blue, right side white.

    (So symlink to file?)

    The last three are white.

    (So files?)

    I added the lines spaces to help separate; also noted the
    directories and what might be a time stamp.

If all the fonts files in that directory are real font files, not links, 
then this should get them installed as fonts:

*sudo su*
*cd /usr/share/fonts/truetype*
*ln -s /usr/share/mythtv/fonts mythtv-fonts*

and now running this:

*fc-list | grep -i droid*

should show all the Droid* fonts.

    barry at Backend-3:~$ sudo su

    [sudo] password for barry:

    root at Backend-3:/home/barry# cd /usr/share/fonts/truetype

    root at Backend-3:/usr/share/fonts/truetype# ln -s
    /usr/share/mythtv/fonts mythtv-fonts

    root at Backend-3:/usr/share/fonts/truetype# exit


    barry at Backend-3:~$ fc-list | grep -i droid

    /usr/share/fonts/truetype/droid/DroidSansFallbackFull.ttf: Droid
    Sans Fallback:style=Regular

    barry at Backend-3:~$

    So only the one?

I tried swapping my config.xml file on my main MythTV box to the one I 
use to access my mother's MythTV box, and it all just worked, as it did 
on v29. So I am not sure why you are having trouble doing something similar.

    Somewhere somehow a big error occurred. I try to follow instructions

In your RPi log, I do not like the look of the "SRSL you shouldn't see 
this!!" errors I see there. I have never seen them before. A quick 
search of the source code suggests that you should only get that message 
if mythfrontend receives a message intended to be sent by mythbackend to 
itself or another backend. So maybe the RPi mythfrontend is connecting 
to the wrong port on BE3??? Given that error, it is not surprising that 
you also get "Failed to open socket, error was malformed_ann_query" and 
"Failed to open remote file"

    Noted that “SRSL” error – whatever that is. At that point when
    sending I had figured not going off on my own exploring to find the
    answer might be a good idea temporarily; will look for an answer
    after posting to you. May be as simple as the RPi needing to have a
    SSH open. (The “SSH” is just something in a chart I remember on the Pi.)

So exactly how are you running mythfrontend on the RPi? What is in the 
config.xml file? Is that RPi used for accessing other backends? If so, 
how do you get it to swap between the backends?

    That particular RPi is a brand-new unit, using MythTV-Light, and
    only looks only at BE-3. Where we do most of our TV watching there
    is a computer configured to BE2 and a RPi configured to BE1. Switch
    HDMI source to select between computer (BE2) and RPi (BE1).

    The new RPi only looks at BE3, or right now tries to, and is up here
    in the Computer Room while I work on it.

    Computers and RPi’s will be moved around, updated and reconfigured
    when BE3 and its Frontends are available. I will admit it’s
    confusing. BE1, BE2, BE3 and their associated Frontends are all
    separate systems.

It would also be very useful to see the section of BE3's mythbackend.log 
file from when the RPi was trying to play a BE3 recording.


    Start June 1 after 10:39:41

    RPi already at the “Watch Recordings” screen.

    Jun 1 10:54:38 Backend-3 mythbackend: mythbackend[1276]: I
    ProcessRequest mainserver.cpp:1780 (HandleAnnounce) MainServer:
    MainServer::ANN Playback

    Jun 1 10:54:38 Backend-3 mythbackend: mythbackend[1276]: I
    ProcessRequest mainserver.cpp:1785 (HandleAnnounce) MainServer:
    adding: rpi(55d5c882dd40) as a client (events: 3)

    Jun 1 10:54:38 Backend-3 mythbackend: mythbackend[1276]: E
    ProcessRequest mainserver.cpp:1727 (HandleAnnounce) MainServer:
    Received malformed ANN query

    Jun 1 10:54:38 Backend-3 mythbackend: mythbackend[1276]: I
    MythSocketThread(66) mainserver.cpp:7980 (connectionClosed) Control
    sock(55d5c8836210) disconnected

    Jun 1 10:54:38 Backend-3 mythbackend: mythbackend[1276]: I
    MythSocketThread(64) mainserver.cpp:7928 (connectionClosed) Playback
    sock(55d5c882dd40) 'rpi' disconnected

    Jun 1 10:54:41 Backend-3 mythbackend: mythbackend[1276]: N Expire
    autoexpire.cpp:261 (CalcParams) AutoExpire: CalcParams(): Max
    required Free Space: 1.0 GB w/freq: 15 min

    barry at Backend-3:~$

    So seems whatever question Ann is asking… <semi-joke>

When using mythexport/mythimport, you get your recordings with all their 
data in the recordings tables, so they show up as normal recordings. 
However, if your channel tables differ between the two systems, you will 
get either the wrong channel information displayed (if the chanid from 
BE2 matches a different channel in BE3), or you will get the channel 
information displayed as #xxxxx where xxxxx is the chanid for the 
channel on BE2. This does not cause any problems at all with playback of 
the files, as MythTV is very tolerant of little things like this, but 
just looks a bit ugly on screen.

    Maybe with “BE4” I’ll try moving the entire database across but
    because of the changes and work and some recordings already in place
    I’m going to go with the mythimport/mythexport option. Channel
    tables will probably differ, more interested in the show than the

    OK, sending this up and see what I can find about Ann and her friend

    Thanks again!


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mythtv.org/pipermail/mythtv-users/attachments/20190601/7783d824/attachment.html>

More information about the mythtv-users mailing list