[mythtv-users] FireTV 4K stick

John Pilkington johnpilk222 at gmail.com
Mon Aug 26 11:35:44 UTC 2019

On 25/08/2019 16:20, Peter Bennett wrote:
> On 8/24/19 3:56 PM, John Pilkington wrote:
>> My earlier report wasn't quite accurate.  The Fedora adb successfully 
>> installed your .adk and I had been able to set the backend address and 
>> accept the options for Backend Ports and Frontend Host Name (Android), 
>> but then useful responses stopped.
>> I reinstalled and did the same again, and 'More' gave a scrollable 
>> screen of recording thumbnails.
> It is supposed to show a row for each title with episodes scrolling left 
> to right. Under "More" there is a grid option which I don't think is 
> very useful. Did you not see any rows above the "More" row?

I've just gone through the setting backend process again, and got as far 
as the blue left-hand bar with a lens and an android green logo; then 
got the Android home screen again...


I've tried some more, but even after clearing the app data (272KB), 
restarting is unpredictable and using the on-screen keyboard to enter 
the IP address gets discouraging.  This system has 409 recordings.

I have had good full-screen playback of DVB-T2 HD content with stereo - 
but then the picture froze while the audio continued;  behaviour seen 
earlier with frontend and mediacodec.  Playback of HD recordings with 
multichannel sound just gives the rotating arrow, or, later, an active 
but non-functional playback-control screen.

It's difficult to make connections between the logs and events.  At one 
stage the JavaBinder reported that:

BinderProxy is being destroyed but the application did not call 
unlinkToDeath to unlink all of its death recipients beforehand. 
Releasing leaked death recipient 

>> I selected a 1080i h264 25 fps with 6-channel AAC/LATM audio - and the 
>> playback-control screen appeared, but nothing more, and on quitting I 
>> got only the repeating ikon.  I tried 'Delete app data' and got back 
>> to the empty Settings screen.
>> I have found it possible to play some of the recordings on this F29 
>> test box, but at present would not choose this way to do it: the 
>> format above doesn't play at all, and 'Standard Definition' mpeg2 
>> encoding plays in a series of spurts.  It seems happiest with the 
>> 544*576 h264 encoded format from eg the Smithsonian and PBS America 
>> channels,  but even there the aspect ratio is wrong - it's probably 
>> assuming square pixels.
>> 'adb logcat' works, produces lots of output, and could probably be 
>> usefully filtered.  The main problem at present for me is the tendency 
>> to forget the backend connection settings whenever something goes 
>> wrong or the wrong button is pushed.  I'll keep trying it.
>> So, I guess it's showing promise but isn't yet ready for a global 
>> rollout.  Many thanks for working on it, though :-)
> Thanks  for testing this. Error handling needs to be added to the app. I 
> already noticed the aspect ratio problem so I will be looking into that.
> Let me know what android device you are using and what version of mythtv 
> backend you have.

There were typos in these version numbers:  corrected version here

FireTVstick 4K bought last November in the UK from Amazon:
Fire TV Home Version

Software Version Fire OS (NS6265/2157)
auto updated during the past week
last checked and up to date yesterday, 24 Aug 2019

Storage capacity 2.76 GB of 5.28 GB available;  I saw an 'out of memory' 
at some stage in the log.  Several other apps are installed and most are 
rarely used.

I also saw a list of supported resolutions that didn't obviously include 
1920*1080, which is what I have:

u4res_ntsc u4res_pal u4res_4k u4res

Mythbackend on Fedora 29 Core2duo 2.66 GHz, 3.8 GiB ram:
current master 477ddfd


> Peter

More information about the mythtv-users mailing list