[mythtv-users] FireTV 4K stick

John Pilkington johnpilk222 at gmail.com
Sat Aug 24 19:56:52 UTC 2019

On 24/08/2019 16:34, Peter Bennett wrote:
> On 8/24/19 3:26 AM, John Pilkington wrote:
>> I have tried to install Peter's new Android-studio based build in 
>> Fedora 29 with KDE, but no luck so far.  The ikon displays but 
>> attempts to activate just return almost immediately to the ikon. 
>> That's after an adb install of the posted .apk. 
> I just ran another test with a fire stick 4k, first I uninstalled MythTV 
> leanback frontend and then installed the apk that I posted on 
> bintray.com. Unfortunately it has the same icon as the normal 
> mythfrontend, I will have to fix that. When highlighting it you can see 
> the name displayed so that you know which is which.
> If I select the myth leanback frontend icon in the fire stick 4k for the 
> first time, it opens immediately to its setup page where you have to 
> supply the backend ip address.
> I don't know why this does not work for you. I suggest check in the 
> installed applications that the correct one is installed.
> Perhaps you have a bad adb. The one that comes with android studio is 
> incompatible with one that comes with ubuntu. If you have android 
> studio, run adb from the installed Android/Sdk/platform-tools/adb. You 
> need to specify the port by running
> adb connect [ip address of fire stick]:5555
> If you still cannot launch the leanback frontend, run adb log while 
> trying to launch it and see if there is a relevant error message.
> Peter

My earlier report wasn't quite accurate.  The Fedora adb successfully 
installed your .adk and I had been able to set the backend address and 
accept the options for Backend Ports and Frontend Host Name (Android), 
but then useful responses stopped.

I reinstalled and did the same again, and 'More' gave a scrollable 
screen of recording thumbnails.

I selected a 1080i h264 25 fps with 6-channel AAC/LATM audio - and the 
playback-control screen appeared, but nothing more, and on quitting I 
got only the repeating ikon.  I tried 'Delete app data' and got back to 
the empty Settings screen.

I have found it possible to play some of the recordings on this F29 test 
box, but at present would not choose this way to do it:  the format 
above doesn't play at all, and 'Standard Definition' mpeg2 encoding 
plays in a series of spurts.  It seems happiest with the 544*576 h264 
encoded format from eg the Smithsonian and PBS America channels,  but 
even there the aspect ratio is wrong - it's probably assuming square pixels.

'adb logcat' works, produces lots of output, and could probably be 
usefully filtered.  The main problem at present for me is the tendency 
to forget the backend connection settings whenever something goes wrong 
or the wrong button is pushed.  I'll keep trying it.

So, I guess it's showing promise but isn't yet ready for a global 
rollout.  Many thanks for working on it, though :-)


More information about the mythtv-users mailing list