[mythtv-users] Max partition size?

Matt Dorsch mtusers at dorscm.wakeful.net
Sun Apr 7 01:22:37 UTC 2019

Good evening,

I just replaced a 4TB drive with a 10TB drive. A directory on the 4TB drive
was one of my recording storage directories. After swapping drives, MythTV
Backend no longer reports the new drive as a storage drive. I don't see
anything in the log about the storage directory not being found. I've tried
removing the directory from the list of storage directories and then
re-adding it. Still no dice.

These are the steps I used to replace the drive:
1. Partition the new drive: one 10TB partition.
2. mkfs to make an ext4 filesystem.
3. mount the new partition at /mnt/onsite-linux.
4. rsync -X --delete -a /home3/* /mnt/onsite-linux
    /home3 is the mount point for the drive/partition being replaced.
5. umount the new partition.
6. assign a UUID to the new  partition.
7. update /etc/fstab with the new UUID.
8. shutdown
9. swap drives
10. boot

The new partition is mounted. I can see it just fine through other means,
but mythbackend doesn't seem to want to use it. Any thoughts?

For now, I've unmounted the new partition and remounted the old one.
Mythbackend is happy again.

If needed, I can resize the partition, either with a tool (theoretically
avoiding a recopy) or via repartitioning and recopying.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mythtv.org/pipermail/mythtv-users/attachments/20190406/c42f1646/attachment.html>

More information about the mythtv-users mailing list