[mythtv-users] Recording failure.

Allen Edwards allen.p.edwards at gmail.com
Wed Apr 3 05:45:14 UTC 2019

On Tue, Apr 2, 2019 at 7:08 PM Allen Edwards <allen.p.edwards at gmail.com>

> On Wed, Feb 20, 2019 at 10:18 AM Allen Edwards <allen.p.edwards at gmail.com>
> wrote:
>> On Fri, Feb 15, 2019 at 9:31 PM Allen Edwards <allen.p.edwards at gmail.com>
>> wrote:
>>> This happened again today. I was able to do some experiments this time
>>> so I have new data.
>>> I ran the HDHomerun_Config gui and both HDHomerun devices were missing.
>>> I power cycled the HDHomerun units and no difference.  I also ran
>>> <hdhomerun_config 10137DC1 set /ir/target "
>>> no_clear"> before and after power cycling the HDHomerun units and linux
>>> just gave an error message <unable to connect to device>. This is the
>>> command I use in rc.local to configure the units on power up. Power cycling
>>> the mythbox without power cycling of the HDHomerun boxes fixed the issue.
>>> I noticed this evening because the remote would not work (the HDHomerun
>>> has the ir reader).  We went ahead and watched our evening show without
>>> issue using a keyboard for control. Then I ran my tests after we were done
>>> watching.
>>> I also noticed that our 3PM show did not record but the 8AM show did
>>> record. The 3PM show comes on again at 6PM and myth tried to record it both
>>> times but failed.
>>> This sure looks like something new to Mythbuntu 16.04.1 LTS. I ran the
>>> same hardware with Mythbuntu 8 for ten years without this happening.  It
>>> seems to happen not quite once a month and the unit is on 24/7.
>>> Any ideas?  I don't know what to do.
>> This is an update.  I think the consensus is that this is a network
>> problem. I got the suggestion from Silicondust that I see if the HDHomeRun
>> units are visible from my Windows computer on the same network.  I also set
>> the IP addresses as reserved in case it is a router problem although that
>> seems very unlikely. At this point I am going to wait and see if it happens
>> again and them do some troubleshooting.
>> I guess there is a legitimate question if the drivers on Mythbuntu 16
>> could be incompatible with my old motherboard.  I never had this problem
>> with Mythbuntu 8 which I ran on the same hardware for many years. Something
>> like this happened on my video card drivers causing many hours of
>> troubleshooting and way more learning about video drivers than I expected
>> to need.
>> Should be using a different network driver?
>> Here is some information from lspci -v
>> 02:00.0 Ethernet controller: Qualcomm Atheros Attansic L1 Gigabit
>> Ethernet (rev b0)
>>         Subsystem: ASUSTeK Computer Inc. P5KPL-VM Motherboard
>>         Flags: bus master, fast devsel, latency 0, IRQ 26
>>         Memory at febc0000 (64-bit, non-prefetchable) [size=256K]
>>         Expansion ROM at feba0000 [disabled] [size=128K]
>>         Capabilities: [40] Power Management version 2
>>         Capabilities: [48] MSI: Enable+ Count=1/1 Maskable- 64bit+
>>         Capabilities: [58] Express Endpoint, MSI 00
>>         Capabilities: [6c] Vital Product Data
>>         Capabilities: [100] Advanced Error Reporting
>>         Kernel driver in use: atl1
>>         Kernel modules: atl1
>  It has been about 6 weeks since the last time my Linux computer lost its
> connection to my HDHR boxes. At that time my assignment was to do some
> troubleshooting.  It looks a lot like a Linux problem.  Here is what I
> observed.
> 1) The remote was not working
> 2) I saw that all the shows since the morning show were errored and not
> recorded as described previously.
> 3) HDHR Config on the Myth computer did not show any HDHR units connected
> like it usually does
> 4) HDHR on my Windows 7 computer showed the four tuners just like it
> always does.
> 5) I rebooted the Linux computer without touching the HDHR boxes or
> anything else
> 6) Everything is working again.
> Thus I can conclude it is not a problem with the HDHRs.  It is not a
> router or switch problem. It is a problem inside the Myth box either
> hardware or software.
> As I have said, this hardware has worked for 10 years under Mythbuntu 8
> without issue. But there were some changes
> 1) New video card
> 2) Added some new RAM
> 3) New hard drive
> 4) Installed Mythbunty 16 (clean install, not an upgrade).
> I have no other problems with the system.
> Any ideas?
> Allen

This from syslog:

*Apr  2 13:07:36 NewMyth avahi-daemon[755]: Withdrawing address record for on enp2s0.*

And this bug without solution

Not sure what to do.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mythtv.org/pipermail/mythtv-users/attachments/20190402/30efcc0b/attachment.html>

More information about the mythtv-users mailing list