[mythtv-users] rpm build of master for el7: fails to build plugins

John Pilkington johnpilk222 at gmail.com
Wed Sep 19 22:22:57 UTC 2018

Hi:  This post is mainly for Gary.  el7 again!!

I have a successful build of fc27.x86_64.rpms for master from a few days 
ago, using this script as is.


Yesterday I tried to build for el7 (CentOS 7).  The MythTV rpms built ok 
but the plugins failed.   It looks as if the special measures taken to 
get a new-enough version of libvpx from COPR haven't worked for plugins, 
although the correct packages were loaded during the MythTV build.


libvpx-1.7.0-7.el7.x86_64 1536084917 2352464 
a8acfbf5ca4f178dd234ac968541d08d installed

libvpx-devel-1.7.0-7.el7.x86_64 1536084917 3228101 
60efbe5182e998e0d340c4afda6c76c1 installed

Extract from root.log of plugins build

DEBUG util.py:579:  Executing command: ['/usr/bin/yum-builddep', 
'--installroot', '/var/lib/mock/centos-7-x86_64-john-3174/root/', 
with env {'TERM': 'vt100', 'SHELL': '/bin/bash', 'HOME': '/builddir', 
'HOSTNAME': 'mock', 'PATH': '/usr/bin:/bin:/usr/sbin:/sbin', 
'PROMPT_COMMAND': 'printf "\\033]0;<mock-chroot>\\007"', 'PS1': 
'<mock-chroot> \\s-\\v\\$ ', 'LANG': 'en_GB.UTF-8', 'LC_MESSAGES': 
'C.UTF-8'} and shell False
DEBUG util.py:492:  file:///tmp/tmp.DD3L62tdpi/results/centos-7-x86  51 
MB/s |  52 kB     00:00
DEBUG util.py:492:  epel                                            7.4 
MB/s |  15 MB     00:02
DEBUG util.py:492:  RPM Fusion for EL 7 - Free - Updates            3.1 
MB/s | 318 kB     00:00
DEBUG util.py:492:  centos 7 x86_64 - base                          6.4 
MB/s | 9.7 MB     00:01
DEBUG util.py:492:  centos 7 x86_64 - updates                       6.3 
MB/s | 6.5 MB     00:01
DEBUG util.py:490:  BUILDSTDERR: Failed to synchronize cache for repo 
'gtb-libvpx', disabling.   <-################
DEBUG util.py:492:  Last metadata expiration check: 0:00:00 ago on Tue 
18 Sep 2018 23:07:51 BST.
DEBUG util.py:490:  BUILDSTDERR: Package gcc-c++-4.8.5-28.el7_5.1.x86_64 
is already installed, skipping.
DEBUG util.py:490:  BUILDSTDERR: Package gcc-4.8.5-28.el7_5.1.x86_64 is 
already installed, skipping.
DEBUG util.py:490:  BUILDSTDERR: Error:
DEBUG util.py:490:  BUILDSTDERR:  Problem: package 
mythtv-devel-30.Pre.776.g926d6150a9-100.el7.noarch requires mythtv-libs 
= 30.Pre.776.g926d6150a9-100.el7, but none of the providers can be installed
DEBUG util.py:490:  BUILDSTDERR:   - package 
mythtv-libs-30.Pre.776.g926d6150a9-100.el7.x86_64 requires 
libmythavcodec.so.58()(64bit), but none of the providers can be installed
DEBUG util.py:490:  BUILDSTDERR:   - conflicting requests
DEBUG util.py:490:  BUILDSTDERR:   - nothing provides 
libvpx.so.5()(64bit) needed by 
DEBUG util.py:634:  Child return code was: 1


The command line I used, on the fc27 box, was

  ./BUILD_MYTHTV_RPMS -r build_cfgs/centos-7-x86_64-rpmfusion_free.cfg 

although the intended target system is running Scientific Linux 7x (ie 
7.5).  I don't think the build system knows that, and I hope it won't 
affect installation when a build eventually works.

The SL7 box has been running V30-Pre-11d42, but with vpx disabled in the 
build, for several weeks.  TTBOMK I don't need it.


John P

More information about the mythtv-users mailing list