[mythtv-users] Sony Android TV does not play AVC [h.264] recordings from MythTV UPNP - but from MiniDLNA

John Pilkington johnpilk222 at gmail.com
Fri Jun 22 11:43:46 UTC 2018

On 20/06/18 06:24, Philipp Hahn wrote:
> Hello John,
> Am 18.06.2018 um 23:56 schrieb John Pilkington:
>> On 17/06/18 09:50, Philipp Hahn wrote:
>>> I have a Sony KD-55XE8096 TV, which is powered by Android TV.
> ...
>>>> $ curl -I  http://scout.fritz.box:8200/MediaItems/25.mpg
>>>> Server: Debian DLNADOC/1.50 UPnP/1.0 MiniDLNA/1.2.1
>>>> Content-Type: video/mpeg
> ...
>>>> $ curl -I
>>>> Content-Disposition: inline; filename="13150_20180611154300.ts"
>>>> Content-Type: video/mp2t
>>>> Server: MythTV/29.1-9-gd9d702526b-dirty Linux/4.9.0-6-amd64 UPnP/1.0
> ...
>> I've read the responses to this and am puzzled.
> /me too as they were talking about some future MytvTV App for Andoid.
>> Your post shows Content-Type: video/mpeg (plays, miniDLNA) and
>> Content-Type:  video/mp2t (does not play, MythTV)
>> I have used DLNA to play assorted video files on my Panasonic TV, on
>> monitors using recent VLC and on an Android tablet using IIRC AnDLNA and
>> kodi.
> I also have tried VLC and Kodi from the App store, but they did not find
> my MythTV system - at least not using UPNP.
>> DLNA servers have been MythTV and Twonky-on-a-Seagate-NAS.  Results can
>> often depend on the filename suffix, or on presentation as a 'video' or
>> a 'recording'   Audio files .mp2 do not play, renamed .mp3 and they're
>> fine.
> If I remember right I also tried to rename one of those .ts files to
> .mp4, .m4v and .mts, but it did not work. But I'm not that this was
> related to the TV doing some caching. I'll repeat that test.
> I haven't yet looked in the MythTV server source code if it is easy to
> patch the mime type returned by MytvTV, but that's also on my todo list.
> Philipp

Re-sending to list.

I'm now back in my usual environment aand might be able to do a few 
tests, although my only HD tuner seems to have developed usb problems.

It occurs to me that your new h264 recordings may have extra streams 
that are confusing things.  I've just added an updated 
mythTScut_20180622.sh to the end of this page.  It might be worth a look.



More information about the mythtv-users mailing list