[mythtv-users] xmltv grabber scripts failing

Mark Perkins perkins1724 at hotmail.com
Fri Jan 12 23:55:50 UTC 2018


On 13 January 2018 7:29:39 am Tim Draper <veehexx at zoho.com> wrote:

> I've no idea what's happened here, but my BE is now failing to run the 
> grabber scripts with perl issues.
> It has been running fine as i have guide data up to tomorrow morning, but 
> no further. mythweb is showing a potential grabber error.
> I run mythfilldatabase and shows grabber script errors so i look at that 
> side of things with the following results:
>
> as root user:
> Name "Params::Validate::NO_VALIDATION" used only once: possible typo at 
> /root/perl5/bin/tv_grab_zz_sdjson line 238.
> You need to configure the grabber by running it with --configure
>
> as mythtv user:
> Can't locate XMLTV.pm in @INC (@INC contains: /usr/local/lib64/perl5 
> /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl 
> /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at 
> /usr/bin/tv_grab_zz_sdjson line 52.
> BEGIN failed--compilation aborted at /usr/bin/tv_grab_zz_sdjson line 52.
>

Possibly when running as mythtv user your environment is not set correctly. 
Possibly you are running as "sudo -umythtv mythfilldatabase" from a prompt 
logged in as your desktop user?  Running something like "export 
PERL5LIB=/.../.../" with path to XMLTV.pm might get past this error but it 
may just fail at the next. Instead maybe try logging in as user mythtv (or 
specifically the user that runs your BE) on a different tty (on Centos 
ctrl+alt+f[2-7]) and run mythfilldatabase from there.

But neither of these may be the problem your backend is seeing. What shows 
in the BE log?




More information about the mythtv-users mailing list