[mythtv-users] 0.28.1 to 0.28.2 upgrade - can no longer configure metadata for tv

Paul Gardiner lists at glidos.net
Sun Apr 15 10:14:08 UTC 2018


On 14/04/2018 20:33, Graham Smith wrote:
> On Saturday, 14 April 2018 4:00:47 AM AEST faginbagin wrote:
>>
>> I suspect you and Graham are just now encountering the issue fixed with
>> this ticket:
>> https://code.mythtv.org/trac/ticket/13084
>> I don't know why you weren't having problems getting TV series metadata
>> before now. But I'll bet that now your problem is missing and/or out of
>> date python packages. If so, you will need to upgrade and install some
>> python packages so that the new version of ttvdb.py works. The ticket
>> comments should help you figure that out.
>>
> Thank you Helen, it took a lot of mucking around but I ended up correcting the
> problem.
> 
> /usr/share/mythtv/metadata/Television/ttvdb.py
> The modules tvdb_api.py (v2.0 or greater).
> They should have been installed along with the MythTV python bindings.
> Error:(No module named requests_cache)
> 
> But when I went to install requests_cache it said it was already installed
> I think it was confused between the two version of python installed.
> 
> I ended up in frustration installing it from the source package
> pip install ./requests-cache-0.4.13.tar.gz
> Processing ./requests-cache-0.4.13.tar.gz
> Requirement already satisfied: requests>=1.1.0 in /usr/lib/python2.7/site-
> packages (from requests-cache==0.4.13) (2.11.1)
> Building wheels for collected packages: requests-cache
>    Running setup.py bdist_wheel for requests-cache ... done
>    Stored in directory: /root/.cache/pip/wheels/fc/
> b2/40/5b57856e507fd1ba6c0ea50dd5694c053eaea7dce71809a1a7
> Successfully built requests-cache
> Installing collected packages: requests-cache
> Successfully installed requests-cache-0.4.13
> 
>  From there it worked.

Not for me, it doesn't. :-(

$ sudo pip install requests-cache-0.4.13.tar.gz
[sudo] password for root:
Processing ./requests-cache-0.4.13.tar.gz
Requirement already satisfied: requests>=1.1.0 in 
/usr/lib/python3.4/site-packages (from requests-cache==0.4.13) (2.18.4)
Requirement already satisfied: idna<2.7,>=2.5 in 
/usr/lib/python3.4/site-packages (from 
requests>=1.1.0->requests-cache==0.4.13) (2.6)
Requirement already satisfied: certifi>=2017.4.17 in 
/usr/lib/python3.4/site-packages (from 
requests>=1.1.0->requests-cache==0.4.13) (2018.1.18)
Requirement already satisfied: chardet<3.1.0,>=3.0.2 in 
/usr/lib/python3.4/site-packages (from 
requests>=1.1.0->requests-cache==0.4.13) (3.0.4)
Requirement already satisfied: urllib3<1.23,>=1.21.1 in 
/usr/lib/python3.4/site-packages (from 
requests>=1.1.0->requests-cache==0.4.13) (1.22)
Installing collected packages: requests-cache
   Found existing installation: requests-cache 0.4.13
     Uninstalling requests-cache-0.4.13:
       Successfully uninstalled requests-cache-0.4.13
   Running setup.py install for requests-cache ... done
Successfully installed requests-cache-0.4.13

$ /usr/share/mythtv/metadata/Television/ttvdb.py -l em -a GB -M "The 
Walking Dead"

The modules tvdb_api.py (v2.0 or greater).
They should have been installed along with the MythTV python bindings.
Error:(No module named requests_cache)


More information about the mythtv-users mailing list