[mythtv-users] IPTV recorder seems broken -- large jumpy files

Dan Wilga mythtv-users2 at dwilga-linux1.amherst.edu
Fri Apr 6 13:35:36 UTC 2018

On 4/6/18 8:56 AM, Rajil Saraswat wrote:
> On 04/06/2018 06:52 AM, Greg Thompson wrote:
>> Why are your fps jumping around so much? It looks like maybe your ffmpeg command line needs tweaked.
>> _______________________________________________
>> mythtv-users mailing list
>> mythtv-users at mythtv.org
>> http://lists.mythtv.org/mailman/listinfo/mythtv-users
>> http://wiki.mythtv.org/Mailing_List_etiquette
>> MythTV Forums: https://forum.mythtv.org
> It seems to work fine if I run it independently in cli. Also, I have
> noticed that if i use the IPTV recorder in mythtv the stream works fine.
> It is only when using External recorder with ffmpeg when things break
> down. Could this be related how fast Mythtv wants to read from ffmpeg
> and how quickly can ffmpeg deliver?
In my attempts to get the Blackmagic DeckLink to record with Myth, I ran 
into similar problems. It wasn't until I modified mythfilerecorder to 
allow for the stdout of a program (like ffmpeg) to be sent unbuffered to 
the backend that things started to work. You can see my patch here, if 
you want to try it:


More information about the mythtv-users mailing list