[mythtv-users] New installation errors

Dick Steffens dick at dicksteffens.com
Mon Sep 18 05:12:38 UTC 2017

On 09/17/2017 08:24 PM, Mark Perkins wrote:
> On 18 September 2017 10:08:52 am Dick Steffens <dick at dicksteffens.com> wrote:
>> On 09/16/2017 10:12 PM, Dick Steffens wrote:
>>> On 09/16/2017 07:56 PM, Stephen Worthington wrote:
>>> <...>
>>>> Or you can restore an old backup database, and then let mythtv-setup
>>>> upgrade it to the latest schema.
>>> I do have one another machine running MythTV. I'll try to figure out
>>> how to do the backup from
>>> https://www.mythtv.org/wiki/Database_Backup_and_Restore and see how
>>> well that works.
>> Some success. I successfully restored a backup from my older Myth
>> machine. And I saw it convert from the old schema to the new one.
>> mythfilldatabase runs with some errors (too small print to read) but it
>> finished.
>> However, when I run MythTV Frontend from the Applications/Sound and
>> Video menu, it shows up in the task bar, but nothing else happens, and
>> the mouse cursor disappears. Of course, as I'm typing this, (on a
>> different machine) the front end did show up, but had an error message
>> about not being able to connect to ... (the message went away). The only
>> way forward is to open a terminal window, run ps ax | grep myth, and
>> kill the two processes shown.
>> Also, when I try to navigate in Firefox to  http://localhost:6544 I'm
>> told, "Firefox can't establish a connection to the server at
>> localhost:6544."
>> Thoughts on where I should go from here will be appreciated.
>> --
>> Regards,
>> Dick Steffens
> Are you sure the delay is not just mythfrontend upgrading the plugins?
> Happens on first run.

I just tried launching it again. After two and a half minutes I got the 
error message. It was something about could not connect to the backend 
and wondering if it is running. It looks like the backend server may not 
be running because when I went to the terminal window to shut down the 
front end only two myth front end process were running, 
/usr/bin/mythfrontend --service, and /usr/bin/mythfrontend.real, and no 
back end process. The error message popped up again on the front end. 
"Could not connect to master" and MythContext. It also asked if the IP 
address set for it in myth setup is correct. I don't remember changing 
an IP address in myth-setup, but I do remember changing the second entry 
on the relevant page of the backend setup from to, which is the address assigned to this box by my router 
(set to always assign that IP address to that box).

I ran mythtvfrontend from a terminal and saw a typo. I ran myth-setup 
and fixed the typo. I had instead of But, 
when I finished and exited, and it asked about starting the backend, I 
saw this:

rsteff at Jetway:~$ mythtv-setup
mysql: [Warning] Using a password on the command line interface can be 
ERROR 1045 (28000): Access denied for user 'mythtv'@'localhost (using 
password: YES)
/usr/bin/mythtv-setup: 42: /usr/bin/mythtv-setup: status: not found
Gtk-Message: GtkDialog mapped without a transient parent. This is 
[FAIL] Starting mythtv-backend (via systemctl): mythtv-backend.service 
Gtk-Message: GtkDialog mapped without a transient parent. This is 
rsteff at Jetway:~$

There must be something else I need to do.


Dick Steffens

More information about the mythtv-users mailing list