[mythtv-users] mythtv-light under raspbian stretch

Mike Bibbings mike.bibbings at gmail.com
Sat Sep 9 14:23:11 UTC 2017


On 09/09/17 14:59, Jeff wrote:
> On 21/08/17 21:38, Peter Bennett wrote:
>> Raspbian stretch is just out. Hopefully it will be a better version. I
>> am working on building and testing MythTV. It looks like raspbian has
>> caught up to libtag1v5, which we have already been using on ubuntu for a
>> while. Also maybe stretch comes just in time for the updated ttvdb.py,
>> which cannot run on jessie.
> I see that you have indeed now created packages for stretch. Thanks for
> your work. Unfortunately, they don't work for me:
>
> $ mythfrontend
> mythfrontend: error while loading shared libraries: libGLESv2.so: cannot
> open shared object file: No such file or directory
>
> Which is strange, as it is installed:
>
> $ ldconfig -p | grep GLES
> 	libbrcmGLESv2.so (libc6,hard-float) => /opt/vc/lib/libbrcmGLESv2.so
> 	libGLESv2.so.2 (libc6,hard-float) =>
> /usr/lib/arm-linux-gnueabihf/libGLESv2.so.2
> 	libGLESv1_CM.so.1 (libc6,hard-float) =>
> /usr/lib/arm-linux-gnueabihf/libGLESv1_CM.so.1
>
> $ sudo ln -s libGLESv2.so.2 libGLESv2.so
> $ mythfrontend
> mythfrontend: error while loading shared libraries: libexiv2.so.14:
> cannot open shared object file: No such file or directory
>
> And here I am out of luck, as .13 is installed:
>
> $ ldconfig -p | grep exiv
> 	libexiv2.so.13 (libc6,hard-float) =>
> /usr/lib/arm-linux-gnueabihf/libexiv2.so.13
>
> Any pointers on how to get things working (and yes, I did run rpi-update)?
>
> Regards
>
> Jeff
>

Did you update the pi firmware as indicated in 
https://www.mythtv.org/wiki/Raspberry_Pi

i.e.
If you are running the August 2017 version of Raspbian Stretch you will 
need to upgrade the firmware, as follows.
sudo apt update
sudo apt dist-upgrade
sudo rpi-update

Mine would not work until I did this.

I suspect the September version of Raspbian has the same issue but I 
have not tested this.

Mike

Mike


More information about the mythtv-users mailing list