[mythtv-users] Playback Flickering After Upgrade to 0.28.1

Brandon Wells wellsb.prog at gmail.com
Tue Oct 24 02:18:08 UTC 2017

On Sun, Oct 22, 2017 at 2:06 PM, Peter Bennett <cats22 at comcast.net> wrote:
> On 10/22/2017 11:47 AM, Jay Foster wrote:
>> On 10/08/2017 08:12 AM, Saul A. Peebsen wrote:
>>> On Sun, 8 Oct 2017 07:38:32 -0700
>>> Jay Foster <jayf0ster at roadrunner.com> wrote:
>>>> On 10/08/2017 07:27 AM, Saul A. Peebsen wrote:
>>>>> On Sun, 8 Oct 2017 07:11:56 -0700
>>>>> Jay Foster <jayf0ster at roadrunner.com> wrote:
>>>>>> On 09/30/2017 04:19 PM, Jay Foster wrote:
>>>>>>> I updated my Intel NUC 7I5BNH frontend from 0.27 to 0.28.1. Now
>>>>>>> during playback, I get a flickering black bar on the screen (like
>>>>>>> a vertical blanking field).  I'm using the OpenGL playback (VAAPI
>>>>>>> is not supported on my HW AFAIK, Intel VGA Device 5926, Intel Iris
>>>>>>> Plus Graphics 640).  This was not there with 0.27. Anyone know
>>>>>>> what this is and how to fix it?
>>>>>> This flickering black line only seems to happen with 1080i TV
>>>>>> playback. 720P and 480i programs seem unaffected.  Also BD rips
>>>>>> seem unaffected. Any ideas what broke in 0.28?
>>>>> You can use vainfo to determine what VA-API modes are supported.
>>>> vainfo reports:
>>>> libva info: VA-API version 0.35.0
>>>> libva info: va_getDriverName() returns 0
>>>> libva info: Trying to
>>>> open /usr/lib/x86_64-linux-gnu/dri/i965_drv_video.so libva info:
>>>> Found init function __vaDriverInit_0_35 libva
>>>> error: /usr/lib/x86_64-linux-gnu/dri/i965_drv_video.so init failed
>>>> libva info: va_openDriver() returns -1 vaInitialize failed with error
>>>> code -1 (unknown libva error),exit
>>>> I am not using VAAPI.  Playback was very good with 0.27.  Why has
>>>> 0.28 broken it?
>>> You really should consider using VA-API with this hardware, it supports
>>> even HVEC 10 bit hardware decoding. I wish my NUC had this capability.
>> I still have no idea how to fix this.  Worked fine in 0.27, but no longer
>> with 0.28.  I tried Normal High Quality, and the black flickering band went
>> away, but then I have tearing.  I tried OpenGL Normal, and the black band
>> went away, but so did the deinterlacing.  While changing the playback
>> profiles, I also noticed that the on screen pop up background color changed
>> from black (I think) to a cyan color.  No idea what caused that either.
>> VA-API is not an option, since there is no driver support for my hardware.
> I suggest try OpenGL slim. Also edit the playback profile once you have
> selected it and make sure Max CPUs is set to 4 (or the number of CPUs you
> have if less than 4). Disable OSD fade. If you then find deinterlacing not
> working, try changing the deinterlacer to Bob or Kernel.
> Make sure in Appearance settings that you disable "separate modes for GUI
> and TV playback" and that your paint engine is not set to QT.
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://lists.mythtv.org/mailman/listinfo/mythtv-users
> http://wiki.mythtv.org/Mailing_List_etiquette
> MythTV Forums: https://forum.mythtv.org

VAAPI is just the interface to the driver. When you see a '-1' like in
your output it means the driver is not installed. If you want to use
the stock Linux driver I think it is 'i965-va-driver'. That is the
easiest to test.

I use the updated Intel version of the driver from
01.org/linuxgraphics/downloads/ which uses 'libva' which you can see
in my NUC output below. You might need the latest from Intel to get
the Kabby Lake support for your CPU but I'd first try the distribution
version which is an easy install.
I updated to Mythbuntu 17.04 on my Frontend so I could use the latest
Intel driver which does a passable HEVC decode on my older Haswell.

$ vainfo
libva info: VA-API version 0.40.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/i965_drv_video.so
libva info: Found init function __vaDriverInit_0_40
libva info: va_openDriver() returns 0
vainfo: VA-API version: 0.40 (libva )
vainfo: Driver version: Intel i965 driver for Intel(R) Haswell Mobile - 1.8.3
vainfo: Supported profile and entrypoints
      VAProfileMPEG2Simple            : VAEntrypointVLD
      VAProfileMPEG2Simple            : VAEntrypointEncSlice
      VAProfileMPEG2Main              : VAEntrypointVLD
      VAProfileMPEG2Main              : VAEntrypointEncSlice
      VAProfileH264ConstrainedBaseline: VAEntrypointVLD
      VAProfileH264ConstrainedBaseline: VAEntrypointEncSlice
      VAProfileH264Main               : VAEntrypointVLD
      VAProfileH264Main               : VAEntrypointEncSlice
      VAProfileH264High               : VAEntrypointVLD
      VAProfileH264High               : VAEntrypointEncSlice
      VAProfileH264MultiviewHigh      : VAEntrypointVLD
      VAProfileH264MultiviewHigh      : VAEntrypointEncSlice
      VAProfileH264StereoHigh         : VAEntrypointVLD
      VAProfileH264StereoHigh         : VAEntrypointEncSlice
      VAProfileVC1Simple              : VAEntrypointVLD
      VAProfileVC1Main                : VAEntrypointVLD
      VAProfileVC1Advanced            : VAEntrypointVLD
      VAProfileNone                   : VAEntrypointVideoProc
      VAProfileJPEGBaseline           : VAEntrypointVLD

More information about the mythtv-users mailing list