[mythtv-users] UPDATE 3: Re: WinTV-dualHD TV Tuner now found (2 tuners!)

A. F. Cano afc at shibaya.lonestar.org
Sun Oct 1 20:54:35 UTC 2017

On Sun, Sep 17, 2017 at 04:57:46PM -0400, I wrote:
> On Sun, Sep 10, 2017 at 07:03:59PM +0100, Ian Campbell wrote:
> > ...
> > Linux has a merge window open now, so fingers crossed for this patch
> > going in for v4.14!
> I hope it makes it into stretch-backports soon!
> ...

I went looking for any indication as to when the 2-tuner patch is going
into the queue of which kernel and didn't find anything, so decided to
apply the patch myself and build a new kernel.

On a test machine:

Installed (via aptitude) linux-source-4.12.  Ended up with
linux-source-4.12.tar.xz in /usr/src.

cd /usr/src
tar -xvJf linux-source-4.12.tar.xz

The 2-tuner patch is here:


Copy/pasted it into a file


cd /usr/src/linux-source-4.12
patch -p1 <

patching file drivers/media/usb/em28xx/em28xx-cards.c
patching file drivers/media/usb/em28xx/em28xx-core.c
Hunk #1 succeeded at 637 (offset -1 lines).
Hunk #2 succeeded at 1089 (offset -1 lines).
Hunk #3 succeeded at 1107 (offset -1 lines).
Hunk #4 succeeded at 1126 (offset -1 lines).
Hunk #5 succeeded at 1141 (offset -1 lines).
Hunk #6 succeeded at 1160 (offset -1 lines).
Hunk #7 succeeded at 1176 (offset -1 lines).
patching file drivers/media/usb/em28xx/em28xx-dvb.c
patching file drivers/media/usb/em28xx/em28xx.h

cd /usr/src/linux-source-4.12
cp /boot/config-4.12.0-0.bpo.1-amd64 .config

The custom kernel installation instructions here:


are outdated.

make-kpkg is no longer available in stretch, so had to look around.
Apparently the same can be done now with just

make deb-pkg

This generated

# ls -sh ../*.deb
11M ../linux-headers-4.12.6_4.12.6-4_amd64.deb
38M ../linux-image-4.12.6_4.12.6-4_amd64.deb
522M ../linux-image-4.12.6-dbg_4.12.6-4_amd64.deb
920K ../linux-libc-dev_4.12.6-4_amd64.deb

# cd ..
# dpkg -i linux-headers-4.12.6_4.12.6-4_amd64.deb

Rebooted kernel 4.12.6 and kde/plasma/X didn't come up.  Had to do an

update-alternatives --all to see what was the matter, glx was
pointing to /usr/lib/nvdia (auto mode), changed it to
/usr/lib/mesa-diverted (manual mode).  After a reboot it
worked.  Not sure why this was pointing to nvidia, this machine has a
Radeon HD GPU.  Possibly a left-over from the upgrade from jessie to

mythtv-setup didn't work either.  It couldn't access the database.
This has happened before when there has been an upgrade and mythtv was just
upgraded to 0.28.1, so had to do (as I did before in this situation):

# mysql -u root (no root password set)
mysql> grant all privileges on mythconverg.* to 'mythtv'@'localhost'
identified by 'mythtv' with grant option;
mysql> grant all privileges on mythconverg.* to 'mythtv'@'%'
identified by 'mythtv' with grant option;
mysql> flush privileges;
mysql> quit

and it worked.  Is this step required for everyone after a myth upgrade
or is there something peculiar about my installation?

Had to set up a new capture card.  It was recognized as

/dev/dvb/adapter1/frontend0 (the first one was /dev/dvb/adapter0/frontend0)

New video source (Tuner 2) with EIT only.

Input connection: associated with Tuner 2.

Did a channel scan.  Now I have 2 entries for every channel (one for each
tuner), but the frontend reports the usual list of channels (72) with no
duplication.  I presume this is the correct procedure to have the EIT
scan work on both tuners.

Then repeated the whole procedure on the main myth machine.  In the
meantime, the kernel source had been upgraded.  The new kernel source
says SUBLEVEL=13 (in Makefile) and the previous one said SUBLEVEL=6.
The newer kernel still didn't have the 2-tuner patch.

So now I have kernel 4.12.13 (patched) installed.  Myth is configured
for 2 tuners and for a while I was still getting conflicts where there
should have been none.  I suppose it was a matter of time for the system to
propagate the fact that there are now 2 tuners into the databases etc...

In the end: SUCCESS!!  A huge thank you to the developers.


More information about the mythtv-users mailing list