[mythtv-users] mythweb - 0.28 - partially displayed page only

Mark Perkins perkins1724 at hotmail.com
Wed Feb 22 07:21:18 UTC 2017

Thankyou Peter and Stuart for the assistance. I have now managed (unfortunately purely by luck) to somewhat have worked out what the issue is. Although I don't understand it.
I have my systems installed to custom paths like:

By using the prefix switch at compile time:

So (as I understand it) stock standard mythweb install doesn't work because mythweb can't find the php bindings in the standard location.

So I had added this line to the .php location in my nginx conf file to add the php binding location to php-fpm:
fastcgi_param   PHP_VALUE  "include_path=/usr/local/mythtv_0_28/share/mythtv/bindings/php/";

Which works - to the extent that it appears that php can access the bindings. However it appears to simultaneously break the include paths (or something, I don't really know and I couldn't work it out despite trying for quite a while) for the php modules. Specifically after including the PHP_VALUE line it appears to silently fail/stop/complete around line 30 of mythweb.php which is:
    if (Modules::getModule($Path[0])) {
Specifically none of the subsequent if / elseif / else statements are executed (as best as I can tell).

My workaround is to replace line 17 of mythweb.php
    ini_set('include_path', '/usr/local/share/mythtv/bindings/php/'.PATH_SEPARATOR.'/usr/share/mythtv/bindings/php/'.PATH_SEPARATOR.ini_get('include_path'));

With the location specific to my individual installs, ie:
    ini_set('include_path', '/usr/local/mythtv_0_28/share/mythtv/bindings/php/'.PATH_SEPARATOR.ini_get('include_path'));

and omit the PHP_VALUE line in the nginx conf files and everything springs to life.

I also learnt that restarting nginx after making changes to the fastcgi_param values does not clear them out. I needed to restart php-fpm as well. Probably should have been obvious to me but I had missed it.

It also appears that the error regarding recommend_enabled setting being null was a red herring. After I worked the above out I went back and changed recommend_enabled back to null and it all works perfectly fine.

On the plus side I now have mythweb working on my internal network at /mythweb_0_27/, /mythweb_0_28/ and /mythweb_0_29/ behind a reverse proxy on port 80 of my backend server. And there was much rejoicing.

Thanks again for the assistance!

More information about the mythtv-users mailing list